Unable to connect Mi table lamp to the Yeelight or Mi App


#1

Dear Sir/Madam
I bought Mi LED desk lamp and 4 pcs of Yeelight Color. This was shipped from China to India at Bangalore.

I was able to connect the 4 pcs of Yeelight Color and was able to configure and play with colours. Update of the firmware for Yeelight Color was also successful . I have used Yeelight as well as Mi App on iOS 11.4 on iPad.

With the same app when I add to connect Mi LED desk lamp , it is not successful . Was quite unhappy. Here is what I tried.

With Server configured to Singapore, the app was able to discover the device after reset with a name “yeelink-light-lamp1_miapf087 on the Wifi , after selecting the name and going to the app it eithers times out, or continue to spin with 10% or sometimes with 25%.
Now I changed the server to Mainland China , I get the same result.
Did many times reset by using a pin to reset , but with no result.

Any help to connect the App to Mi LED lamp will enhance the trust on Mi brand.


#2

Hi, I tried using the Mi Home App.
Here are the steps.

  1. Choose Mi LED table lamp.
  2. Did the reset . Reset successful.
  3. Wi-Fi password entry successful
  4. Under IPad Wi-Fi, Yeelink-light-lamp1_miapf087 appeared. Choose this name.
  5. Went back to Mi home. And started to show the percentage progress and showed 100%
  6. After this it turned to screen again to reset and again the above cycle repeats.
    Will be great help if there is any suggestion.
    My ID is 5158736195.

#3

Could you see the lamp in your router’s DHCP list after the connection failed?


#4

Hi
I did not see any entry in the DHCP list.
Regards
-Niraj


#5

So this is the problem, there’s problem when the bulb try to connect your router. please use another phone to setup a hotspots with 4G network and try connect the bulb to it.


#6

Hi
I tried connecting through the phone using hotspot. This also did not work.
So my question is how how come Yeelight is perfectly working.
Secondly are you saying that the entry should be there in the dhcp list?
Regards
Niraj


#7

Hi
Whenever you try connecting the desk lamp, it goes 100% and again throws back the reset screen. I think this is the issue
Regards
Niraj


#8

You should login to the administration page of your router, then check if there’s AP named like yeelink-light-lamp1*** in the DHCP list.


#9

Thanks Andy. I will try tonight and keep you posted.


#10

Hi Andy
Here is an update . I am using Dlink Covr Router (https://covr.dlink.com/covr-3902.html)
It does not give the DHCP list but when I reset the table lamp and connect through the yeelight app on iPad , the list of connected client is seen in the Router list. I have attached the snapshot. After then in the yeelight app it shows 25% complete and then says connection failed.
Regards
-Niraj


#11

Any update. What should I do next.


#12

Actually, I got no idea about the issue. As the lamp has already connected to router, so the issue could be at when the lamp try to connect to the cloud. And you said you have other 4 Yeelight color bulb that work well, I don’t know why it failed.

Could you use another phone to setup a hotspots with 4G network and try connect the bulb to it.

Thanks,
Andy


#13

Thanks Andy . I did try creating a hotspot from 4G Network and again this time the Mi Home as well as Yeelight apps on Android do the job but when it reaches 100% , throws a message “Timed Out”
All my Yeelight color bulb works flawlessly.

It looks to me that there is no issue with the Hardware. It is a software issue. I hope you are working to get this rectified.

Regards
-Niraj