Unable to connect light anymore


#21

Sorry, I forgot to mention, you should connect it to China server. Please reset the bulb, re-connect it to China and then share it with that account.


#22

@weiwei Ok I’ve reset it and connected to China server and shared it again.


#23

I have downgraded your bulbs to old version, please check if you can use this version to connect to your router.


#24

@weiwei hi I’ve tried again on wifi to connect both on China and Singapore server but with both it fails at 25% while connecting.

I’ve used wireshark to capture the network traffic when trying to connect to the Singapore server. I’ve uploaded the file to https://ufile.io/q6tfz


#25

I checked the capture packages and found the bulb is sending DHCP request while there is no ACK from your router. The request sent by the bulb is valid (confirmed by wireshark decoder), so it should be the compatibility issue. I don’t know why it used to be working… Have you updated the firmware of your router?

DHCP procedure:

  1. DHCPDISCOVER : From DHCP Client to DHCP Server, to find the DHCP server on the local network

  2. DHCPOFFER : From DHCP Server to DHCP Client, to offer the IP Parameters

  3. DHCPREQUEST: From DHCP Client to DHCP Server, giving a request to get the offered IP Parameters

  4. DHCPACK: From DHCP server to DHCP Client, giving confirmation to use the the offered IP parameters.


#26

@weiwei as far as I know the router hasn’t changed it’s firmware since it worked. It’s possible the has been a firmware update as some are automatic but I can’t check at the moment.

The bulb doesn’t have a static IP address set on the router, although when it tries to connect I can see it seems ot be allocated the next free address each time.

Is there any ports that the bulb would need opening on the router to be forwarded to allow the router to send the ACK to the bulb?


#27

No, the bulb uses the standard UDP port for DHCP.
If you can connect the bulb through your phone’s hotspot, that means the bulb’s DHCP is good.
If you can connect other devices through your router, that means your router’s DHCP is good.
The only conclusion we can get is that: there is some optional field in the DHCP procedure that caused the failure.

Do you have other Yeelight devices at your home? Do you have other Xiaomi smart devices at your home? How about their status?


#28

@weiwei no this is the first Yeelight or Xiaomi device I’ve had. It was fine at first and up and running in a few minutes and was looking good until the firmware update when it disappeared from the devices list.

I will try at a friends as the bulb is working with hotspot so if they can connect to their wifi I’ll maybe buy a 2nd bulb for myself and try it.

I’ll check the date of the routers firmware when I get home in case it changed. Is that just port 80 that it uses?


#29

Hi @weiwei I’ve checked my router and it hasn’t had an firmware changes since I first used the bulb.

I’ve noticed that there are new versions of both the MiHome and Yeelight app available for the iPhone. I’ve updated my apps and tried to connect with them. I’ve tried using the new USA server as well as trying the Mainland China and Singapore servers as before.

Unfortunately I still haven’t been able to connect the bulb.

I’ve seen that other people have similar problem to me and saw this post - http://forum.yeelight.com/t/cannot-find-bulbs-on-app-after-new-router-installed/2281 - where it seems that the problem was solved by including location permissions for the Yeelight app. I’ve checked on my iPhone and the Yeelight app isn’t listed in the location services section so I’m not sure how to enable that permission. The MiHome app is there and has location services enabled but it didn’t make any difference. Although I can still connect using a personal hotspot without location service enabled so that may not be the problem.


#30

@weiwei I’ve also noticed that after you downgraded the version of the firmware for the bulb it now shows it is version 1.4.1_24

I think when I first received the bulb, and it worked correctly, I was on version 1.4.1_48 of the firmware. Is there any way to get that version of the firmware? At the moment the bulb isn’t linked to my account with trying to reset and connect it.


#31

Well, I’ve never got to the cause of the issue with the bulb stopping connecting to the wifi after initially working. I’d tried all the different suggestions to check my setup for the router and ISP but no luck.

I decided to give buying a new bulb a try. Again it connected first time but has so far stayed connected even after a few weeks. I’ve been using it in the same place as the previous bulb. I haven’t changed anything with my setup for the wifi.

I tried using the original bulb again but it still fails to connect and stays at 25% before time out in the app.

As the bulb seemed to work fine if I setup a hotspot with my phone, I can only think that the first bulb is some how faulty. I’ve noticed a lot of people having the same issue with their bulbs too so it’s possible that the bulbs may have been part of a faulty batch.

Hopefully the fault won’t occur over time on the new bulb.


#32

I’m having the same problem with my Yeelight LED strip. Timeout eventually at 25% with wifi.
No problem installing when using mobile data hotspot…
Hoping to exchange a new unit to test again.


#33

@pete_l @Pspower

Please provider you information:
1、 Your Mi ID;
2、 Which server do you connected.
3、 The time you connect to cloud failed.

We will find out connection log from the cloud to see what’s going on.

And BTW, you can add my WeChat with “Andydingding”, thanks!


#34

@dingyichen
Hi Andy

I’ve just tried reconnecting the first bulb I had onto my account but after taking a little while getting the connecting message and staying on 25% the connection failed again.

My Mi Id is 1726106272 and I’m currently connected to the United States server. The failed connection would have been around 1900-1905GMT on 10th December

My other bulb is connected Ok to my account.

Peter


#35

Where is your location, it seems you miss something.


#36

Hi, @dingyichen I’m based in UK so the failed connection should show up around 1900GMT. I’m not sure what timezone you use so thought I would include mine to help.

Peter


#37

I am having the same problem I have 7 bulbs two are color all setup just fine but one of the color bulbs just cycles through the colors then turns white and flashes twice then shuts off I have tried the yeelight tool as well I am going crazy I have been trying for a month and a half…please help


#38

@Buddha9008 Hi, I doubt this will be much help but I never resolved the problem with my bulb that wouldn’t connect.

I took it to a friend’s however and it connected fine to their router/network and worked ok for them - they have the exact same ISP and router model as me so that would prove that my setup should have worked fine. Not the best solution but I think it gave me an indication as to what the problem was.

I think the issue with the bulb I had was that it failed to complete a firmware update properly while connected to my router. After that whenever I tried to connect the bulb the router must have be blocking it from connecting, either because it already thought they was a device using the same IP address or for some other unknown reason.

To me this would mean that short of replacing the router, or resetting it back to default settings and wiping all the devices configured on it there wouldn’t be anything I could do to resolve the problem. Given that it’s about 4 months since I first had the problem, and all of the other people posting with similar problems since then, it doesn’t look like anyone (Yeelight or another user) has thought of a solution either.

The other bulb I bought works fine still though :slight_smile:


#39

Thank you for the info I just have to find it in my router and delete it then cross my fingers lol maybe one day I will get to it. Thanks again pete


#40

Yes unfortunately my router doesn’t allow you to search for devices to remove them unless they are actually connected… a bit of an issue in this case!