Trying to enable developer mode with YeeLight app - lamp always offline

I’m trying to enable developer mode on my new RGB Wifi bulb to use it with Corbin’s wonderful Domoticz plugin.
Because I did not know any better, the first app I tried was MiHome.
Yes, I got it to work eventually, and the bulb can be controlled.
But to enable developer mode I am now trying to use the YeeLight app.
This app always says the bulb is offline, although it works perfectly well with the MiHome app.

Any ideas how to get it working?
Several lamp resets have not succeeded.

Could you use Yeelight app to add the bulb after your reset the bulb? The Yeelight app and MiHome app actually use the same cloud server, it’s supposed to see the same state of the bulb.

Account 1648836277
Thanks Weiwei.
The YeeLight app added the bulb automatically (as offline) the first time I ran the app.
No amount of resetting changes that.
It is as if the bulb is registered exclusively to MiHome.

Could you try logout from Yeelight app and re-login?

OK, I’ve logged-out of MiHome.
Logged-out and back into Yeelight.
The lamp was online when I logged-out of MiHome.
It is detected by an IP scanner.
It is still offline in YeeLight.

If I try this command on my Raspberry -
printf ‘{“id”:1,“method”:“toggle”,“params”:[]}\r\n’ > /dev/tcp/
I get -
-bash: connect: Connection refused
which I guess means it’s online but not in developer mode.

Further update -

The lamp suddenly connected to the YeeLight app.
There was no developer mode in the options.
I was able to rename the lamp.
It had firmware 1.2 something, with an option to upgrade to 1.4 something.
The upgrade got to 100% but no further messages.
The lamp is now offline again!

Logout and back into HiHome - lamp is online!
Firmware is 1.4 but lamp has its old name.
Logout and back to YeeLight, lamp stubbornly offline.

It’s really strange. A couple of questions: Did you change your Mi account password recently? Could you control your bulb from MiHome? Could you logout Yeelignt app and login again?

Hi Weiwei, thanks for all your help.
I’ve never changed my password, and MiHome worked fine for control.

I deleted the device in MiHome, and logged out.
Logged into YeeLight, after resetting the bulb.
After a couple of minutes it detected the bulb.
There was a tiny red blob on the tools icon, which I’d seen before, but had not explored.
And after setting developer mode Domoticz has control.