Yeelight RGB V2 connection issues

This yeelight bulb is driving me crazy. I can not get it connected with the yeelight or mi home app. Reset the light for like 1000 times. If i select the bulb i get an connection time out notification all the time. Sometimes it will connect over WiFi or directly when i selected the yeelink-light-color2_miap7516 in my WiFi list but after connecting it does not show up on the dashboard and gives an server error 1011 above.

It was working okay for a few days before i changed the SSID of my router. With the new SSID now luck, set the router back to stock settings also connection issues now.

my ID is 1701196755 on china mainland server.

Do you mean you can connected the bulbs successfully, but there’s no bulb in the list cause of 1011 error?

Yes when I can connect that’s correct. But most of the time I get the connection time out notification.

I have reset my router to stock settings but now I can not connect to the yeelight bulb at all.

Is there any support yet? I have still no solution.

Please check if the bulb connected to your router, if yes, please have a try changing DNS of your router to

How can I check? See if the Mac adres is known by the router?

I have checked it but the Bulb is not connected to my router. All is see in my router is other devices which are connected.

I have also tried to connect my bulb with a tablet and used my phone as a hotspot (so cancelled my home router in between) but also no luck.

Generally, it works well if you setup hotspots with another phone, and connect the bulb to it. Please check it again, if yes, try changing DNS of your router to, reset the bulb, connect again.


like yourself, I am having this problem, already reseted the mi led smart bulb 100000times and it doesnt work! when it is connecting, at 26% it skips that part and asks me for location(room) and name, and then it doesn’t show in the app.
I’ve read hundreds of forums, seen youtube videos, tried router & hotspot configurations suggested, also tried to log off/log in, tried another smartphone, even tried closer to the router to eliminate wifi signal loss and nothing worked!! the weirdest thing is that I have an older yeelight color bulb in for use for the last few months and it works like a charm!

i’m about to give up and return the bulb!

if anyone has another suggestion, please give me a shout!