Yeelight bedside lamp can't connect

Hi community.

I can’t connect my bedside lamp to my Honor 10 (Android 9)
Lamp model:

I tried to connect via Yeelight app and Mi home app, both don’t see the lamp at all.
Tried to reset the lamp of course (plug off, hold the button, plug in, wait, release the button).
Tried China, Autstalian, Russian servers
I can see the XMMCTD_ device in my bluetooth list

Do you know what can I do to use my lamp? :slight_smile:

Hi dingyichen, can you help me?

Please grant all permissions that the app wants, and make sure please open location(GPS) of your phone.

Done, same story :<

All other Xiaomi devices working fine via MiHome app.

But can’t connect the lamp using MiHome or Yeelight app

dingyichen, anything else I can do?

We will take a look at the issue to see if it related to Android version.

Hi, any news related to this problem?

@ dingyichen
Hi, still trying to solve this issue :<
Really like the lamp, don’t want to make a refund.

Mihome and Yeelight application would take XMCTD_ as Yeelight bedside lamp, please double check what’s the name you see in bluetooth list?

Yes, it’s XMCTD_ , sorry.

Hi @dingyichen

I’m sorry,but I can’t connect to my lamp again.

I don’t see the device via bluetooth/yeelight app/mi home app.
Last time I found it via bluetooth, connected and then found in in yeelight app. But I can’t do the trick again.

The phone is the same, it’s pixel 3a with the latest Android .

Could you please advice what can I try to do?