[Solved] Connection timeout - wrong region?


#1

Hi!

I have been trying for hours to set up my Mi Bedside Lamp I got yesterday, but everytime I want to add it to the app, it says that the connection timed out. It connects fine to the wifi, but does not seem to be able to communicate with the app.

By capturing my network traffic I discovered that the lamp is communicating with the server at 47.88.172.135, but my phone talks to different servers. I assume I have selected the wrong region in my phone? Is there a way to find out which region this server belongs to?

I have tried everything from different phones, different wifi networks (both, dsl and mobile hotspots), different DNS servers, different regions (not yet all of them), different app versions. I am running out of ideas…

My account id: 6152219646

Thanks!

Edit: Problem solved! Turns out the lamp was still running on an old firmware. After using an older account as described in Connection timeout issue I was able to add the device and update the firmware. Afterwards I could add it to my own account.


#2

Thanks for feedback, which device do you have, could you post a picture of the lamp?


#3

Mi Bedside Lamp (the one with the golden colored base). The model is MJCTD01YL. Do you still need a picture?

I have another issue with it that does not allow me to save scenes (I made a separate Post about it). Could that be related?

Thanks for your support! Let me know if you need more information.


#4

That’s ok, thanks for your information.

I will take a look at the issue. We are on holiday of China spring festival now, it will take some days to fix.


#5

Thanks! No hurry, take your time and enjoy the holidays :slight_smile:


#6

I just confirmed with my colleague that the issue would happen with the device that made with very old firmware. Thanks for your information.