One of my yeelights cannot connect to router


#1

Hi there,

i have installed 2 Yeelight 650ceiling lights today. I added the first one to my Mi Home app with noe problem. The second one however does not connect: I get a “connection timed out” error, no matter how often I try.

The light definitely is connected to the router as I can see both lights in my router’s DHCP list and can also ping their IP addresses.

My ID: 6150264443


#2

Any update?

Please check if the lamp shows in device list when connection timeout, this may happens sometimes even the lamp has connected successfully.


#3

Unfortunately, this is not the case. Neither in the Mi Home, nor the Yeelight app.

Edit:
Is it maybe possible to add the lamp to the devices list manually?


#4

Hey, I’ve resorted to replying to to other threads because no Yeelight Staff has commented in the 1 percent brightness thread in over a month. We have a bunch of people waiting hoping to have access to the experimental firmware. Any chance we could get that processed?


#5

Have no idea why the first lamp works well, could you try with changing DNS of your router to 8.8.8.8?


#6

Hi, we have not find a decent way to fix the issue, these days we are working on Homekit support for v2 bulb and the latest beta version is for Homekit instead of 1% brightness. We will release a new firmware once we resolve the issue.

Thanks for understanding.


#7

I really appreciate the response, but honestly I’m happy with horrible color accuracy at low brightness. I want what everyone else was using a couple months ago!

I’m using home assistant, I can easily do my own bulb-specific per-brightness color calibration. If there is anyway to make a side branch of firmware with the color fix it would be amazing for all of us. Even if only the while LEDs worked in low brightness mode, and anything with color was brighter, that would be a start.


#8

Yes, i have tried everything I found in this forum regarding this problem, including changing the DNS server to 8.8.8.8 and trying to host a wifi hotspot with my mobile phone and connecting the lamp to another phone connected to the hotspot.

I have also 3 more yeelight bulbs that work perfectly fine so the question is not “why is one of the light s working” but “why is one of them NOT working”

Is there any chance you could manually set up the lamp in my account? If not, then I can probably trash it… This is really frustrating and I’m also afraid to buy a replacement in case it has the same problem.