Yeelight Led Ceiling lights / IFTTT cannot find group or scene


#1

Hi,

I have

  • two Yeelight [YLXD05YL] 480 LED Ceiling Lights
  • two Yeelight [YLXD01YL] 320 Smart LED Ceiling Lights
  • one Yeelight LED Bulb II (White)

They all work properly with the Yeelight app, separately and as a group I made. I can also command them with voice via Alexa. I can makes scenes in the app.

In IFTTT the individual lights work in the applets separately, BUT I cannot use them as a group or a scene. For example: I want the lights to shut down when I leave my apartment, so I choose the location perimeter on the map, and when it asks to choose the light I can see the list of the lights but not the group I have made of the same lights.

When I try to circumvent the problem by making my own applet: location “you exit an area” -> Yeelight set scene (all lights are added in the scene with scene action being “turn off”) -> “There was a problem processing the request” and it freezes with “loading”, does not show a scene list and because of that does not let me create the action.

Do I have to add the lights one by one, by making 5 identical applets and choosing the approximately same map point for each, or is there a better fix for this?

I have tried both German and Singapore servers with same setup, and the problem stays the same too.

My MI ID is 1839706918. I would really appreciate all the help and tips I could get to solve this, Thanks!


#2

Had change Application server for IFTTT just those days.
Pls try again.and if not works,please tell me.


#3

This is still not working for me. When trying to set up an applet on the IFTTT website, I see the following web traffic in developer tools:

Toggle lights on/off (working)
request: https://ifttt.com/stored_fields/options?resolve_url=/stored_fields/actions/yeelight.on_off/device_id/options&authenticity_token=Tv8u5765RRtYt%2Bsj5GlYh%2B9qjpotLRMP1gjTa7OWjtOoiyVSvtWZI3Pp3%2Fftfy5ZugYx5dtlk76Aa9koPeS9NA%3D%3D

response: {"device_id":[{"label":"bedroom overhead 1","value":"87570083@us","group":null},{"label":"bathroom 4","value":"87603200@us","group":null},{"label":"bathroom 2","value":"87603233@us","group":null},{"label":"bathroom 3","value":"87603247@us","group":null},{"label":"bathroom 1","value":"87603628@us","group":null},{"label":"bedroom desk","value":"87612565@us","group":null},{"label":"bedroom overhead 3","value":"87612968@us","group":null},{"label":"bedroom closet","value":"87613601@us","group":null},{"label":"bedroom overhead 2","value":"87613702@us","group":null}]}

Set Scene (not working)
request: https://ifttt.com/stored_fields/options?resolve_url=/stored_fields/actions/yeelight.set_scene/bundle_id/options&authenticity_token=Tv8u5765RRtYt%2Bsj5GlYh%2B9qjpotLRMP1gjTa7OWjtOoiyVSvtWZI3Pp3%2Fftfy5ZugYx5dtlk76Aa9koPeS9NA%3D%3D

response: {"bundle_id":null}


#4

It seems that you hadn’t create a scene bundle and add your lights in.
Please confirm that situation.