Strip not responding to multicast request

I would like to control YeeLight Strip Plus using my Android app. So I have enabled the LAN control using YeeLight app.
After that, I have installed YeelightDemo app and click the “Search” button, but not working.
Can you help me asap?


I have encounter the same issue with some Android devices, this is caused by there’s not set CONFIG_IP_MULTICAST config when building linux kernel. Please have a try with other phone, but I am not sure if it is ok.


Thank you for your reply.
but I have tried this for 3 android phones, but all are same.
Is there any resolution for that?

No, maybe you can try with laptop.

I would like to control my device using android phone.
In this case, without using third party protocol, How can I do?

Now, I can control my device using your YeeLight app. But In this time, I am going to control this device using my custom android app, in this case, how can I do?

There’s an app named “Yeti” that supports yeelight device with Lan control, you can download it and have a try to see if it works well. If yes, maybe there’s some bugs in demo application.

I have downloaded Yeti app and tried to find.
But this app says to me “No devices found”.
I have enabled Lan control of my device in Yeelight app.
But this app says to me “No devices found”.

but I can still control using YeeLight app that you have offered when I buy device.

So this is an issue of your phone that doesn’t support sending multicast group message. I have no idea about the issue, please try more android phone :joy:

Can you give me sample device that I can implement?

I have tried using Samsung Galaxy 6.0, 7.0, 8.0, and Huawei 8.0.
But not working for all deivces.

I have no list of device which supports Multicast, I tried with Huawei device, which is also not support. I don’t have Samsung devices, seems it doesn’t support either.

I also tied with some xiaomi devices and Smartisan devices that can successfully send multicast messages. But I am not sure if all of its devices support the feature.

Now, I can control my yeelight device using Yeelight app.
The purpose to buy this yeelight device is to control this device in my android custom app.
So in this case, how can I do that without using lan controlling?
Is there any way to control my yeelight light strip plus device without using lan controlling enabled?
such as like yeelight app.

If you know ip address of the bulb, you can type ipadress to setup a socket manually to control the strip locally.

The purpose of using multicast to search device is to get IP address of the devices nearby, then setup a socket with the Ip address to control.

I have used my local ip address directly.
I have got this ip address from the yeelight app.
but it occurres “connection timeout” error.

Please refer to

If you can control it the lamp with your terminal, so please double check your code.

Make sure put your phone and the lamp in the same network.

Good luck.

Okay, thank you.
Let me try now.