Yeelight connection problem with Google Home

Hi everyone,

I just bought two new Yeelight LED Bulbs, and with the Yeelight app, they fully work as expected.

The problem comes when I try to connect the Yeelight service to Google Home, because I simply can’t connect them.
I search on the Internet, expecially in this forum, and I think I tried every possible solution I found, but nothing works.

A quick recap of what I have done:
First of all, obviously, I followed the instructions in the Yeelight app, to connect the Bulbs. Worked correctly
Then it was time to try connecting them to Google Home, via the Google Home Android app (quick spoiler: nothing worked):

  • The first time I simply try to connect the service in the Google Home app, login at Xiaomi Account page, and then, when the page returns the message “Account linked”, closes the browser but nothing happens. No Yeelight service in “My services” and no page in which select which light I can add to my room.
  • After searching in this forum, I tried to reset my bulbs, and retried the 2.2 point. Same result.
  • Tried to re-reset the bulbs and changing the server in the Yeelight app, again 2.2 and nothing.
  • Reset my Google Home Mini, point 2.2, and nothing.
  • Keep changing server, in order to try them all, deleting the bulbs from one and add again to the other, and keep trying login to the service in the Google Home app, but what I gained was the same “nothing-happened” result.

One of the common problem I read was because maybe my ISP may block the connection to the Yeelight/Xiaomi servers, but I think this is not my case because I can correctly login both in the app and the browser, from different devices too.

Yeelight App and Google Home app are at latest version.
Bulbs firmware also updated at latest version.
My phone is an OnePlus 6, updated to the latest version of Android.
I’m from Italy, and my actual server in the Yeelight app is German, the recommended one.

I sincerely don’t know what to do, because one of the reason I bought 2 Yeelights, was the compatibility with Google Home and routine/custom commands.

Can you help me somehow, in order to connect my account to the Yeelight service in Google Home app?

Thanks in advance.

Exactly same problem. I attempted change default browser, downgrade Google home app. Opt out from yeelight beta.

Nothing worked.

As a workaround I managed to easily connected yeelight with ifttt and ifttt with Google assistant.
After that I was able to control yeelight with Google voice.

But is shame that native advertised solution not working.

Even with IFTTT, my Google Home tells me to add the devices to the Google Home app before use them, so even with it I cannot make them working

I’m waiting for an Admin or a developer who can tell me how to make them work

Hello, I had the same problem recently. In my case the downgrade of Google Application worked. Did you try it? Go to list of applications on your phone, find Google, select Disable. It will uninstall all updates of Google app and you will have an old version on your phone. Then try to add Yeelight server in Google Home application. When added, it will show you your bulbs. Then you can update your Google application again. It seems there is a problem in latest update of the Google application. Good luck.

@PetrTajovsky Thanks for the tip, everything works now! I downgraded the Google app, added the Yeelight (after 3 tries, but it’s ok :laughing: ), and then update the Google app at the latest from the Play Store.

Thanks bro, I appreciated that :pray:

1 Like

This is Google App’s bug, the 9.0.3 version seems fixed.