Unable to link Yeelight with Google home

Hello I have been trying to connect my yeelight bulb with google home but I am unable to. It says account linked and then nothing happens. I have tried multiple times, but nothing seems to work.
My id is 1906366248

Same issue here, I’ve tried all of the work arounds. Any answers admins?

I have same problem
pls solve it

Hello, same problem here. I can see my Yeelight bulbs in Yeelight application, I can control them from there, but when I try to add my Yeelight account to Google Home, it is still not there. Is there something I should try? My ID is 1809838295. Thanks

Same issue here, on the US server as well. ID is 1913392081.

@yusure

ID is: 1913178652

Hi everyone,

It display “Account link successful” when login Xiaomi account ?

Yep, it’s giving the account successful and then goes back to the home app and doesn’t show it connected/

This is a know issue, reported to Google Team, but still not resolved.

Please try this temp solution:

  1. clear default browser cache.
  2. clear GoogleHome App cache.
  3. Login GoogleHome App and re-link Xiaomi account.

Tried it twice with switching the server from USA to Singapore. Neither worked. Should I be using my email to login or my ID?

You can try Xiaomi ID to login

Still no luck, I’ll keep an eye out for whenever google decides to fix the issue

@ssingiser
Please update “Google” App to 9.0.3 version, this version has been fixed.

Can confirm that the latest update solved the issue, thanks!

1 Like

Same issue , doesnt connect after successful linking. No yeelight prodfucts show on google home , please help

@dkprince23
Hi guy,

Please tell me your Xiaomi ID, I’ll check for you.

@yusure

Hi, I’m trying to link my Yeelight color led bulb to Google Home, but couldn’t succeed. I can see and control my devlce in Yeelight app but can’t see it on Google Home. When I try to add Google Home says successfully linked but device is not visible.

Id: 1885318768
ios: 13.1.1
Server: US

Thanx

Same issue. I tried to fix by following your suggestions but it is not worked. My ID : 1809955251

Hello, I just checked your control logs, it seems ok, So have you fixed it?