Alexa voice control - "Bedside lamp does not support this"


#1

I have a Mi Bedside Lamp (MJCTD01YL) supporting Wifi and acting as a BLE gateway. This lamp can be successfully controlled through the Android Yeelight app, and the Android Mi Home app, on the Singapore server.

The Android Amazon Alexa Echo app is able to control the device, too - on/off, colour, brightness, all good. Alexa voice control through a Amazon Echo Show (second generation) does not work - I only get a response from Alexa " does not support this"

When I say exactly the same phrase, addressing a Mi Desk Lamp, that lamp works perfectly. Both devices are operating through the Yeelight Skill, both are on the same Echo, both are on the same network, …

Note: I am talking to the devices in German language.

What can I do that the Bedside Lamp accepts voice input from Alexa exactly the same way as the Mi Desk Lamp?


#2

The Bedside Lamp is on firmware 1.5.9_0170 (current according to Yeelight app).

I finally also found the LAN control setting - this was disabled (and still I could change the lamp settings via other apps); now it is enabled, and Alexa voice control still does not work.


#3

Solution found:

The Yeelight device had a name which matched an Amazon Echo group name. Because the Amazon Echo group was empty, the group obviously would not support anything at all.

The Amazon Alexa app on Android really should provide some diagnostics / alerts for name combinations which call for trouble.

How did I figure this out? I tried playing with groups and noticed that the Yeelight device inside a multi-device group would correctly respond to voice command. Cue taken - ceate a single devce group. Oh, and now rename the group to … Wait, name already exists? Ooops.

Frankly, the Amazon Alexa app leaves a bit to be desired so far… (I do understand that Yeelight have no control over that ;))


#4

Glad you solve the problem:grinning: