mi desk lamp connection time out


#1

Lamp tells “connection time out” when I connect it to my home network.

When I connect it through hotspot on my phone and it works well. I tune hotspot on phone with name and password like on home router. Lamp works about a week or two after I turn off phone hotspot.

How can I make it work with my home internet provider?

Russia, Moscow, provider MGTS
Россия, Москва, провайдер: МГТС


#2

This is good to try, and it seems the lamp has ready connected with your home internet provider. Do you mean the lamp is offline then? How about turn off the lamp from wall switch and turn on again to see if it will back online.


#3

My lamp had worked about a week or two and after this period it forgot how to connect and switched to offline.
I can connect it again via another phone. But I would not like to do this every week.

I think the lamp wants to connect to the server that my home provider blocks in DNS. When the lamp connects via hotspot on the phone it saves ip-address in the cache and then connects to your servers by ip-address, not by name. When cache becames invalid the lamp again asks DNS and again can’t connect.

I can’t tune DNS server on my router. This option is disabled by provider.

Any ideas?

If you tell me server names I can ask provider why these addresses are blocked.
Or maybe there is possibility to tune the lamp to connect to servers by ip-addresses instead of names? Or something else


#4

I think maybe your ISP block xiaomi server, please have a try to see if the port opens to you:

  1. Download nmap from https://nmap.org/
  2. nmap -sU -p 8053 -Pn ru.ot.io.mi.com
  3. nmap -p 80 -T4 -A -v ru.ot.io.mi.com
  4. From the picture below, type ru.ot.io.mi.com in location 1(de.ot.io.mi.com if you select Germany server, sg.ot.io.mi.com if your select Singapore server, us.ot.io.mi.com if your select US server), and then type Step 2/3 command in location 2, it will show green if the port opens to you.