Device connection issue caused by DNS resolution failure


#1

We have received a lot feedbacks about device connection failure with “timeout” error message.

With the support of several volunteer users from this forum, we found the root cause is DNS resolution failure. After changing DNS from ISP Assignment to static DNS address 8.8.8.8 from Google, most of the connection error cases were resolved.

Now we are trying to figure out who, where and why. If you are facing the same problem, please try the followings:

  1. Try to setup static DNS address 8.8.8.8, usually you can change it in DHCP settings on the web console of your router, if you have no idea how to do that, please contact your ISP for help.

  2. Changing DNS might impact some other VOIP, ITV services from your ISP, if you run into that problem, you can keep the original DNS configuration(it will be Assign ISP DNS in most cases), then retrieve the DNS address assigned by your ISP (Refer to: https://www.cyberciti.biz/faq/how-to-find-out-dns-for-router/).
    Once you get that DNS address, setup static DNS address as step1. You can set ISP DNS as primary and 8.8.8.8 as secondary.

If it works for your case, please let us know:

  1. Which country do you resident?
  2. And what’s your ISP?

Issues with LED Bulb II Color control
#2

#3

Not working for me, tried to switch with many different DNS, but no one working. I’m in Italy and my ISP is Telecom. I’m using a fritzbox 7590


#4

How about using another phone to setup a hotspots with 4G network and try connect the bulb to it?


#5

Hi Andy, done also this one but without success. I used my phone as wifi hotspot and I tried to configure my 2 yeelight with a second phone from the app but still continue to have same problem. I tried to ping German server that I’m actually using and it answer to my ping requests. But there’s no way to setup “manually” the yeelight setting inside connecting to this?


#6

Which country do you live? Have you tried changing DNS to 8.8.8.8 to your router?


#7

I live in Italy, and yes I tested also to switch dns as 8.8.8.8 and 1.1.1.1, but for me is not this the problem because I’m able to ping your servers


#8

Could you see the bulb in your DHCP list? And could you ping it successfully?


#9

Andy, I’ll reply asap. I’m out of home now. Regards


#10

Hi Andy finally I solve. First of all I had to clear and reinstall the yeelight application, then I setup DNS in my router as 1.1.1.1 and 1.0.0.1 and tested is was possible ping de.ot.io.mi.com (german site) and for finish I disable the 5ghz band of my wifi. With those settings in my home i was able to setup immediatelly both my bulbs. Thanks.


#11

Thanks for sharing, the bulb only supports 2.4ghz band. Have a good day.


#12

I don’t think app reinstallation and disable 5ghz has anything to do with this case. Could you please try again and confirm if it’s DNS changing make it happen? Appreciate.


#13

I can confirm that I was able to ping the your server also before with my dns


#14

I get your point. But I suspect there is some compatibility issue between our lamp device and DNS server. So I need you help to confirm if it could work when you change DNS to previous settings.


#15

Using German server or USA yes, not the chinese.