Help with connection timeout.

I can successfully connect my lightstrip untill I get to the actual connecting to router, it goes all the way to 100 then says “connection timedout” how can you help?

I didn’t get your point. Do you mean you can get it connected with mobile hotspot?

No, everytime I try to connect it to my router it just say connection timedout. I constantly try to reset it and I even checked of it shows up on my wifi list

I had the same problem. It was a fault of my Phone (Huawei p20 pro). Try to connect it from different device

I have already tried it with 2 devices, I can try it one more with another.

I tried connecting it with another device, it didn’t work. Help?

Please refer to and provider more information:

I have tried that, I have tried the Gmail, and many other things, none have worked.

Have you tried mobile hotspot?

I have tried that but still nothing works. I went onto our Internet settings and even tried to add on the device with its MAC address. Anything Else i could try?

First, please have a check if strip connected to your router, you can see if it is in DHCP list from your router. If yes, then try changing DNS to

Well my light strips aren’t in my DHCP list but I still tried and it didn’t work.

The bulb can only work with a router using WPA / WPA 2 encryption method with a password, and only support 2.4ghz wifi. Please double check if your router settings.

I don’t have the bulb I have the Light strips

They are the same with wifi module.

Hi, I always get connection time out when i want to add device using my office network but has no problem if i used my personal sim card router.
The office IT support staff said I must give them the service port number of The server I am connecting.
May I know what I should reply to the IT support?
Thank you very much for you help. I am using in Singapore.

In my case the solution was indeed making sure my router and all repeaters or powerlan devices are on WPA2 only as some users already pointed out that some Yeelight products are not supporting other protocols.

My router was set to WPA2/WPA3, while some powerlan devices where still on WPA2 and that combination lead to these timeouts. I had to set my router to WPA2 (no WPA3 anymore) and my lightstrip connected without any issues and works flawlessly now.