Yeelight color bulbs offline


I’m having a lot of issues with my bulbs at home. They are always shown as offline, a few reboots from router or power on off works sometimes but not everytime. They are shown as offline in both Yeelight app and Mi home app.

What’s strange is that my remote to turn on or off works just fine, without any issues. Automation with Mi Home app also works very good, I have automation to turn them on if motion sensor is activated.

I have latest firmware: 1.4.2_0066
According to my router and Mi Home app all lamps have a IP address.
Modelnr: YLDP02YL


So, is there a solution to this or is there an update coming? It seems like I’m not the only one with this issue

I also been having a lot of problems reported here. This make the lights very unreliable to use in a wide scale…


I hope there’s a fix soon. Otherwise I’ll have to go with Philips hue or something.

1 Like

First of all, if both Yeelight app and Mihome show offline, we can say the bulb is actually disconnected from cloud.

Automation could be performed locally on the Smart Gateway, so most likely, the bulb is connected to your home network but disconnected from Xiaomi cloud for some reason.

What’s your router model? And how many clients connected to your router?

1 Like

Hey! I have a TP-link TL-MR6400. I have 15 devices connected through the router and an access point. All devices shows up on my router and all devices have an IP address, including the lamps. But only the lamps shows as offline, no other devices from Xiaomi is offline.

I have a lot of offlines in Home Assistant. Sometimes the offline is just some seconds, but sometimes I get a total blackout, and the bulb stops appearing in my router connected devices list. I have to preform a power cycle to the bulb.

Thank You

1 Like

I reboot my router sometimes too, but for me it doesn’t work. Also power cycle doesn’t work.

@Soloam @jdarchin

Which server do you select? Have you tried with other servers that near to you.

Hey! Ive only tried mainland China. Ill try in Europe tonight

I have no more offline issues. I changed my access point to a more powerful one, bought Asus Lura AC2200 and have no more issues. Don’t know if tp-link had issue with yeelight.

I used TP-Link before, it works well. Could you let us know which model of TP-Link do you use? We will have a try.

Hi again,

It’s TP-link TL-MR6400.

It’s been 3 days now without any issues. Even tried to turn off the power to the bulbs and on again, still works. Earlier when my kids turned the power off, it went offline and I had to repair them.

I just checked product spec for that router, it’s 4G LTE router. Did you use 4G SIM slot or WAN port for the uplink?

4G as I’m using the 4G for internet.

I have this issue with TP-Link Archer C7 v2. It’s been this way for as long as I have had yeelight bulbs and strips, and all are affected. I have 35 devices and they will randomly start to “fall off” the network over time and require a power off and power on. I have waited about a year for the yeelight devs to pick up and fix this issue and it’s a bit crushing to see that you’re still asking people what servers they are connected to when it has been explained in every discussion that it also affects LAN control. It’s your device, since I have easily 40 other smart devices in my home from Xiaomi smart plugs to google homes, broadlink devices, arduinos and smartlife bulbs and other LED controllers none of which are affected.

There’s not going to be any more Yeelight devices on my network until this is fixed. There is no point having smart home technology that I have to manually walk around powering off and powering on to get it back online. This is one of so many threads on this problem and still nothing seems to be done, I think all hope is lost. I will start returning Yeelight devices as faulty because I don’t see any chance of any resolution, Yeelight devs will just keep asking the same questions or wait until people replace their routers and then suggest that was the problem all along.

1 Like


We fixed some connectivity issue when lan control mode is enabled. The patch has been released with version 1.4.2_0070. Please update to this version and see if it works for you. Thanks.

By the way, what’s the status of the bulb when it goes offline? Is it on or off, in color mode or color temperature mode, and the brightness?

Liu Fei

Hi Liu Fei,

I have a lightstrip which has been offline for about a week now, so I can give you the exact status.

When a device goes offline, it is always stuck at its current setting. In my case, it is stuck off however I have had many lights get stuck on with the current brightness and colour, which varies from room to room. There is no specific brightness or RGB colour that causes my bulbs to get stuck.

Here is my Homeassistant view of the two light strips mounted behind my TV:


As you can see, the upper strip is unavailable and the lower strip is available and on. Both of these are plugged into the same power outlet. I try pinging the available strip:

PING xmstrip3.lan ( 56(84) bytes of data.
64 bytes from xmstrip3.lan ( icmp_seq=1 ttl=255 time=1.52 ms
64 bytes from xmstrip3.lan ( icmp_seq=2 ttl=255 time=5.22 ms
64 bytes from xmstrip3.lan ( icmp_seq=3 ttl=255 time=11.0 ms

I try pinging the unavailable strip:

PING xmstrip4.lan ( 56(84) bytes of data.
— xmstrip4.lan ping statistics —
6 packets transmitted, 0 received, 100% packet loss, time 5093ms

The status in Homeassistant shows:

xmstrip4 was in the exact same state as xmstrip3 before it became unavailable. All of the values would be identical as they are using the same scene.

If I power off and power on the strip (which means powering down the whole TV) you can see that it will become available again:

PING xmstrip4.lan ( 56(84) bytes of data.
64 bytes from xmstrip4.lan ( icmp_seq=1 ttl=255 time=2.97 ms
64 bytes from xmstrip4.lan ( icmp_seq=2 ttl=255 time=8.43 ms
64 bytes from xmstrip4.lan ( icmp_seq=3 ttl=255 time=2.56 ms

However in the next few weeks another few bulbs and strips will go offline and I will have to manually reset them like this. By the way, I noticed the blue light was flashing on the controller when I climbed up to power down the light strips at the back of the TV.

Hi Liu Fei,

Any more information you need from me?


OK, I have a bulb that has stopped responding today. I am going to give you any info you need to diagnose why. The first thing I want to show you is below, I have 6 yeelights in a single room only metres from each other, and only 1 of them has stopped working. This is very normal (and frustrating) and will continue to happen, if I left it long enough they would all end up like this. Obviously it’s the one that is still lit, which should have been turned off by a timer when motion stopped but it is now unreachable:

In the app, as you can see, it shows offline:

It does not respond to pings:

6 packets transmitted, 0 received, 100% packet loss, time 5126ms

I check for any instances of its MAC address attached to my router, it is not attached currently. I see all my other bulbs but not this one.

Thankfully my router logs via syslog to a server on my network. I pull up all of the logs and I see:

Bulb with that MAC address was performing handshakes every 10 minutes up until that point (please give me an email address and I can send the full logs to you) UNTIL the bulb itself seems to disconnect:

Dec 9 06:01:15 xxxx hostapd: wlan1-2: STA xx:xx:xx:xx:66:fa WPA: group key handshake completed (RSN)
Dec 9 06:11:15 xxxx hostapd: wlan1-2: STA xx:xx:xx:xx:66:fa WPA: group key handshake completed (RSN)
Dec 9 06:21:15 xxxx hostapd: wlan1-2: STA xx:xx:xx:xx:66:fa WPA: group key handshake completed (RSN)
Dec 9 06:31:19 xxxx hostapd: wlan1-2: AP-STA-DISCONNECTED xx:xx:xx:xx:66:fa
Dec 9 06:31:24 xxxx hostapd: wlan1-2: STA xx:xx:xx:xx:66:fa IEEE 802.11: deauthenticated due to local deauth request

It is not heard from again after this point. Does this not show the bulb disconnecting from the wifi network, and why would it do that? None of the other bulbs surrounding it are affected.