Impossible to pair


#1

Hi,
I just purchased a Mi Bedside Lamp 2nd Gen at the beginning of the week and I attempted many times to connect it with my iPhone X on iOS 12.1.

Every time I want to pair the lamp with the phone, I have this message “Request Time out. Check network connection and try again”. My wifi is working correctly and the password correct… I don’t know what to do.


#2

Hey,

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp by power on and off fives times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

You have a try with:

  1. Use another phone to setup a hotspots with 4G network and try connect the bulb to it.
  2. Try with changing your router’s DNS server to 8.8.8.8 instead of using automatically allocation.

Thanks,
Andy


#3

Hi,

Thanks for the reply.

What do you mean by special character ? Do you consider the dash such a special character ? For example : Test-1234


#4

Character like “/” “`”, dash is ok.

You can have a check if the lamp connect to your router when connection failed.


#5

hello…i got my yeelight bedside lamps just yesterday and i have had major issues connecting the lamps with the app. first i tries with yeelight app and then with mi home app…

I have tried all servers, have reset the lamps multiple times, tried my broadband router and mobile hotspots but no success.

In the Mi Home app, after completion 100% it shows connection time out. In Yeelight app, it progresses to 16% and simply disappears and shows the add device page again and again.

i wonder why is it so complicated

i am using an iphone with ios12 where both yeelight and mi home app are installed and my mihome account is 5195748021

pls help


#6

Yeelight bedside lamp or Mi Bedside lamp? Yeelight bedside lamp is generation one and is bluetooth device.


#7

it is this model…
https://www.mi.com/us/mi-bedside-lamp/


#8

hello? is any one there? pls help otherwise this lamp is useless for me


#9

Disable bluetooth and try again with Mihome app. You will get a popup dialog to prompt enable bluetooth, click somewhere else to dismiss this dialog and click next again. Then following the instruction to continue. Let us know if it could work for you.


#10

so i should only use the Mi home app and not the yeelight app?


#11

That’s just debug trick. Suppose it should work with either of them.


#12

I tired that also and it didn’t work… it’s officia!!! Mii bedside lamps don’t work with apple iOS app… I have literally tried everything


#13

Do you have any other xiaomi iot product? which server did you select?


#14

i have paired my mi air purifier 2 without any issues on my mi app with the india(Asia) server


#15

Do you have Android phone around to have a try?


#16

i will borrow since at home i have all iphones and ipad


#17

Tried it with android too… the phone discovers the lamp and sends a message but on the last stage when it attempts to connect the lamp to the network it fails… both on mi app and yeelight… now both with iOS and android it doesn’t seem to work … maybe it has something to do with router … my whole house works on a hotspot from the central router so don’t think I can do any settings there too… don’t know what’s the solution