Yeelight IFTTT "Could not connect service"

It’s simple: I cant get my Yeelights to connect with IFTTT.
I get the error stated above. It creates a connected app account on my xiaomi account but the error still pops up and I cant use any Yeelight applets.

Could you show me your XIAOMI id please?
And if possible, could you give more detail error information?
Many thanks.

My ID is 1860823261
I open the ifttt app and search an existing applet or create my own for the yeelights
It requires me to log in to my xiaomi account
I enter my credentials and it puts me back to the ifttt app saying “could not connect service”
On my xiaomi account under accounts and permissions I see a new permission created called Yeelight IFTTT. Deleting that and trying to connect yeelight to ifttt again results in the same problem.

I had search the log,and didn’t find your information which connect to IFTTT.
It means that we didn’t receive your oauth information.
Could you give your IFTTT account to help me to debug with IFTTT developer.

My username is enough?
That would be:

Yes,it’s enough.
Will debug it with IFTTT developers together.

Hi I just wanted to ask whether you could get a result or anything yet.
Thanks for the update!!

Still debug it.Or could you please try to visit to find out if it’s something wrong happen.

On there is just the text ‘Yeelight Cloud Manage’ on a blank website

Got it,it seems it’s nothing wrong with your side to our server side’s network.
So,could you please tell me your region/country in order to we contact IFTTT to check it’s network in your region?
By the way, we had faced some other issue which also couldn’t connect to our server, and when they change their default browser to oauth,it works.You can have a try by change oauth browser.

I’m from Switzerland, so the region should be Europe.
I dont think that worked with changing the browser, but I might have done it wrong.

Same problem here. I’m from Germany and on the german server. Tried with different browsers and from the app. MI ID 1897359419

Just ulink the Yeelight service within the IFTTT app, then relink them. Problem solved.

It never was connected, so it didn’t show up in the App…but for some reason it works now. I didn’t do anything different, but maybe you guys did sth…just wanted to let you know.

Still doesn’t work for me @sheldon

Hi,we had report your IFTTT username to IFTTT to ask them check the reason.
They had confirmed the question is network problems and promised will soon report us when some our users face the network problems.
But had’t received their reply.
Had email them a moment ago again.

Hi, can you give me the email address what you used to sign up for IFTTT?

Hi @sheldon sorry for my late response. It should be

Same problem.
Mi ID: 1776749231