Yeeligt v.2 first connection

Hello, I have yeelight colour bulb V2 and I can’t connect it with my WiFi router. I have 3 yeelight bulbs v1 that work perfectly. I see them on my yeelight app and mi home app. I try to explain my problem with V2 bulb. I reset my bulb (switch on and off for 5 times), open yeelight app, press + button, discover my bulb (appear its Mac address), select my bulb, select my WiFi (2.4GHz / WPA2 Security / TKIP ), wait for connecting but it can’t and “time out” message appears. It seems that the bulb can’t switch from ap mode to device mode. Have you got any suggestions? Is it a faulty unit? Thanks

Check if the bulb connects to your router when the connection fails.

If it connects to your router, please leave your 1) xiaomi account; 2) Mac address of the bulb; 3) Server you selected; 4) Time with zone you tried.

Thanks,
Andy

Yes, it’s connect to my router now. My data are:

  1. 24440512
  2. 7c:49:eb:b9:09:b7
  3. mainland China
  4. Italy so GMT+2
    Now, fortunately it’s connected but I can’t see on yeelight app. Can you help me, please?

Which version of Yeelight do you use? How about refresh the list view?

I use the 3.1.73 version for Android. I have refreshed my devices list, but new bulb hasn’t appeared

I can’t see color2 device from your account.

Please try to connect again and tell me the time. I will see the log to know what’s going on.

I’ve just tried, but without success. It connects to my wifi with its IP address 192.168.1.4 but it can’t connect to the server. Time out message. I’ve tried twice

We can’t see any log from cloud, please make sure there’s no some special settings of your router.

I can try, but I’m sure that there aren’t any special settings on my router. It seems that the bulb can’t connect to internet, but the other bulbs don’t have any problems. I’ll try with a gsm modem router.

Update: I put the device into DMZ list, but without success. Are you sure that this bulb is ok? It seems that It can’t connect to your server. If I have router problem none of my bulbs could connect to your server.
Update II: I try with another router without success. Is it possible that my device is on your black list? My device name on router is yeelink-light-color2_miio99425237.

You can’t see any log because this bulb can connect only to my wifi network, but after that it seems that it can’t reach the server and I can’t add it. I tried with mi home app, too without success.

Yes, you are right, there’s some problem when the light try to connect cloud server. And the bulb is good if you can search it from application.

Please have a try with:

  • Please use another phone to setup a hotspots with 4G network and try connect the bulb to it to see if it works.
  • Could you have a try with changing your router’s DNS server to 8.8.8.8 instead of using automatically allocation?

Thanks,
Andy

I tried to use a 4g modem router with the sam results: time out connection. The bulb can connect to the router but it can’t connect to the cloud server. I changed the DNS server and I did a ping test and there is no problems to communicate with the server. I don’t know what is the problem. What about cloud server? Is it possible that It can’t connect my bulb?

Could you try again with smart phone hot spot?

I’ve just tried with my phone as hotspot and an iPhone for configuration. The result is 25% and time out connection. It’s impossible to connect this bulb to your cloud server. I have bought another yeelight bulb on Amazon to test if the problem is the bulb or the connection.

At the end I ordered an other yeelight V2 on Amazon and it works. So, as I thought, my previous yeelight V2 is faulty. I noticed that the previous one is very hot when it’s on, meanwhile the new one is only warm.