Firmware update on yeelight bedside lamps


#1

I have 3 yeelight bedside lamps - 2 pcs with 2.2.31 firmware, and 1 pcs with 2.2.39 firmware.


When I use Mi Home, i see message, that firmware on my 2.2.31 lamps is obsoleted and i need to use Yeelight app to update firmware.

But Yeelight app show, that i use lastest firmware.

How to update the firmware on 2.2.31 lamps?


#2

Profile/Settings/Check for updates, you will see update page.


#3

Yeelight App shows that I use lastest version:


MiHome shows that no updates available:





But actually 2 of 3 lamps have old firmware 2.2.31.
Serial number of one of these lamps:


#4

which server did you select in Yeelight app?


#5

I tried to go through all the available servers in my Yeelight app - –°hina, Singapore, USA, Germany and Russia. Result was unchanged.


#6

We found the root cause. Fix is on the way.


#7

@Korako We have fixed this issue from backend, please try again and let us know. Thanks!


#8

Unfortunately, no changes have happened. After checks of updates versions of firmwares and applications from play market remained same.


#9

App will download firmware and perform update automatically. Try to connect your device again.


#10

I tried to reconnect the device (Reset Yeelight app memory in phone, reset lamp by power button and reconnect power cord, add lamp in application, connect with it). Yeelight app did not perform update automatically. Version of firmware remained same.


#11

Mainland china server?


#12

I tried with China, Singapore and Russia servers. Full reconnection including reset app and device settings I tried with Singapore server.


#13

Did you grant all necessary permission?


#14

Some minor permissions (such as Contacts, Camera and etc) were disabled. Now I set active all available permissions, but lamp is not updated.




#15

With the latest Yeelight app update, this problem also remains.


#16

Today, after switching from China to Russia server, the firmware on the lamps was updated.