Bedside v2 + hygrothermo : remote OK but no history


#1

Hi,

I have a bedside v2 acting as BLE gateway, with an hygro-thermo sensor connected.
My account is connected to the China server.
While away from home, I can see the temperature and hygro data updated in the daily view, so I assume the BLE is working properly.

After a week at home, weekly and monthly views started to show some history.

Then I went away from home for 4 weeks holidays. During that time, the weekly and monthly views were NOT updated anymore, while the daily view kept showing up to date data.

When I came back home, the 4 weeks of data suddenly appeared in the weekly and monthly views after 2 days.
Since then (4 more weeks later), living at home, the weekly and monthly views have NOT been updated anymore. The daily view still works as expected with up to date data.

What can possibly be wrong that prevents weekly/monthly history charts to appear? How can this be fixed? I bought the bedside specifically for the BLE capability in order to get this history, and not having it working is really disappointing.

Thanks for your help


#2

Funny, after the last MiHome app update last week, all data now appears as expected.
Now, the question is: will it keep working day after day?


#3

I don’t think Yeelight is responsible for hygro-thermo history data, cause you can see daily data update from gateway of Yeelight bedside lamp, it means the lamp works well.

Please ask factory of hygro-thermo for more help.


#4

I totally agree, the bedside is working fine.
The fact that all history appeared in graphs after I updated the app is another proof that the bedside works fine and that the server has all the data.
But this is a proof as well that the hygro-thermo works fine too.
The issue is (or was?) either with the data server which holds the data and does not send it back to the app when history graphs must be displayed, or with the app itself. I have to keep checking now with this new updated app (version 4.8.7) if things keep working.


#5

Nope, it started failing again. So I guess the temporary improvement was not thanks to a fix but just due to the installation of the update, unless it was just totally random. Anyway, here’s what’s happening again, without me changing anything since the few days it worked:


#6

I think you can contact hygro-thermo for help, cause you can see real-time data.


#7

So, after some times, I finally understood where the problem comes from:

Every few days, the weekly and monthly graph stop getting new data, as in the picture I uploaded in my previous post.

The way to fix this, every time, is to unplug and replug the power cord from the Bedside.

My conclusion is: after a few days, the bedside stops sending data to the Yeelight server, and rebooting it fixes this.

However, even when it is not sending data anymore, the other functions involving the network of the bedside are still working fine: I can drive it from the app and send API commands from the local network.

Is there any way I can get some logs to better understand what starts failing in the bedside software, to give you a chance to provide a fix ?

My current firmware is 1.5.9_0170, and I’m connected to the China server.

Thanks


#8

All the data is handled by hygro-thermo not Yeelight, Yeelight bedside lamp only works with network gateway. If you can see real-time data, it means gateway works well.

The weekly and monthly data, I guess, save in Hygro-thermo’s server. Data display doesn’t need gateway network. Better to ask hygro-thermo for more information.


#9

I think

  • my phone gets the real-time (i.e. daily) data from bluetooth, as it did before I had a gateway.
  • The bedside, either stops retrieving data from the hygro-thermo, or stops sending it to the server, I have no way to find out which.

Otherwise, how do you explain that rebooting the Bedside always makes the missing data finally appear in the weekly/monthly charts?

Although I’m definitely not convinced that the hygro-thermo is the root cause of the issue, I can follow your suggestion and ask them too. Can you please point me to the appropriate contact/forum?

Thanks


#10

You can have a try to get the data when you away home, then bluetooth don’t work anymore. If you can get still get the data, it means gateway works well.

Sorry, I don’t know either, maybe you will find some clue from their web.