Fixed DHCP address breaks connection unrecoverable


#1

Hi all,

I have the requirement to assign fixed addresses to my light strips.
Adding them with dynamic DHCP addresses causes no issue at all.
As soon as I configure my DHCP server to give them a fixed address, they are no longer reachable by the app.

I already tried resetting the light strip and re-adding it in the app but it gives a timeout after the wifi settings have been configured.
IP wise everything is fine, the address is reachable in my network but I can’t seem to add it in the yeelight app.

The really shitty part is, when I revert it back to dynamic DHCP, it still doesn’t work. I now already have 2 light strips that I am unable to link with the yeelight app.

Are there any specific DHCP options that maybe break the light strips? Or ones that are specifically required (aside from IP config and DNS server)?

Thanks in advance,
Cheers!


#2

Could you have a try with changing your router’s DNS server to 8.8.8.8?


#3

What’s your router model?


#4

Hi, thanks for your response.
To be clear, my router does not do the DHCP. I have an ISC DHCP server set up in my network which runs independently from the router. All the DHCP clients in my network already get 8.8.8.8 as DNS server.
But to answer the question, the router model is an AVM FritzBox 7490.

Could it be an issue that I am configuring my local domain as well when answering the DHCP request?

Sep 11 16:43:30 fry dhcpd: DHCPDISCOVER from 78:11:dc:a2:27:4c via eth0
Sep 11 16:43:30 fry dhcpd: DHCPOFFER on 192.168.2.201 to 78:11:dc:a2:27:4c via eth0
Sep 11 16:43:30 fry dhcpd: DHCPREQUEST for 192.168.2.201 (192.168.2.51) from 78:11:dc:a2:27:4c via eth0
Sep 11 16:43:30 fry dhcpd: DHCPACK on 192.168.2.201 to 78:11:dc:a2:27:4c via eth0
Sep 11 16:43:30 fry dhcpd: Added new forward map from yeelink-light-strip1_miio77096853.home.lan. to 192.168.2.201
Sep 11 16:43:30 fry dhcpd: Added reverse map from 201.2.168.192.in-addr.arpa. to yeelink-light-strip1_miio77096853.home.lan.

Thats how the fixed address looks in the config:
host yeelight-strip1 {
hardware ethernet 78:11:dc:a2:27:4c;
fixed-address 192.168.2.201;
option domain-name-servers 8.8.8.8;
}

Cheers!


#5

So the strips accpeted the fixed IP address because they are reachable locally.
I guess the issue is with the gateway setting or DNS servers assigned. Or maybe the gateway failed to recognize the fixed IP address (if that’ not equal with the automatically assigned one) due to some arp issue if any.

Please check and provide more info (gateway, netmask, etc).


#6

Hi,
these are the options sent to the light strip by the DHCP server (taken from tcpdump).
192.168.2.51 is the DHCP server’s address
192.168.2.201 is the fixed address configured for the light strip
192.168.2.1 is the router’s address

So I guess everything seems to be in order on that side.

17:25:30.015430 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 328)
192.168.2.51.67 > 192.168.2.201.68: [udp sum ok] BOOTP/DHCP, Reply, length 300, Flags [none] (0x0000)
Your-IP 192.168.2.201
Client-Ethernet-Address 78:11:dc:a2:27:4c
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Offer
Server-ID Option 54, length 4: 192.168.2.51
Lease-Time Option 51, length 4: 7200
Subnet-Mask Option 1, length 4: 255.255.255.0
Default-Gateway Option 3, length 4: 192.168.2.1
BR Option 28, length 4: 192.168.2.255
Domain-Name-Server Option 6, length 4: 8.8.8.8
END Option 255, length 0
PAD Option 0, length 0, occurs 20

What I still don’t understand is, why doesn’t it work if I do a reset on the lightstrip and also revert the DHCP settings to dynamic allocation.

Thanks for your input!

Cheers


#7

Any updates? At least how I might be able to reset the stripes? Because right now I am not able to control them in any way… Basic reset (hold button then plug in) does not work.

Cheers


#8

Solution was:
reset strip
connect to strip on another network (i used the hotspot from my mobile)
reset again
create reservation BEFORE connecting
connect to strip
DHCP hands out the reserved IP and I am still able to connect

Still wondering what the actual cause was. Would be nice to get an answer from someone who knows how the product works.

Cheers