Yeelight colour will not work with Google home


#1

Hello. I have tired every suggestion that has been given throughout this site. Changing server (I have tried then all and reset after each one), resetting etc and no matter what I do, my yeelight will not work with my Google home. When I ask it to turn on the light, it says the light has not been setup yet and prompts me to link it to my Google home account. I do this, and I get the notification that it has been successfully linked, but it has not and the cycle begins again. Please help!!

Mi account number: 1744621728

Thanks!


#2

I have a very similar issue


#3

All servers have support Google Home now, you don’t need to reset the bulb.

Could you see the bulbs in GH after you link Yeelight from Home application and discovery devices?


#4

Hi Dingyichen. The bulb has never shown up in GH. I try to connect by choosing yeelight as an option. It says it is connected but it does not show up. When I ask GH to turn on or off the light, it says the light has not been set up and sends a link to my phone so that I may set it up. This process never resolves itself. The GH can see the bulb on the network, but is not linked to the bulb. I hope that helps!


#5

@yusure Please help take a look at the issue.


#6

Hello,

Are you sure use “Yeelight” and not “Mi Home” ?


#7

Yes, I can control the bulb through the yeelight app. I don’t use mi home.


#8

I didn’t find any logs, could you take a screenshot on GoogleHome app ?


#9

Ok. I have attached two images. In one you will see that the yeelight pairing days it has been successful. But as you can see from the image, it has not been added. I have tried everything but nothing seems to work.


#10

How many xiaomi account do you have? Are you sure you login correct xiaomi account in google home app?


#11

I only have one account and that is the one I use to log in.


#12

Please try changing a default browser, don’t use Google browser.


#13

I don’t get to choose the browser, the action takes place within the Google home app.


#14

try to reinstall google home app.


#15

I just tried that, still no change. What could be causing this?


#16

This should be Google browser cache, usually, change default browser can fix it.


#17

I have also tried this and still it doesn’t work


#18

try use another mobile phone :pensive: