Problems with connecting Yeelight Ceiling light

I have this light and i succefully connected it to the WIFI network until today. Totay i changed my WIFI network due to replacing internet company, and i can’t connect the light to the network. I use in MI Home app and the region is Other. The app can’t find the lamp automatically, so i tried to manually choose it, but still can’t connect. I also tried to reset the light (2 sec on, 2 sec off- 5 times), but nothing happened.
Tried also with Yeelight App.
Using 2.4 GHZ network.

Please make sure you have reset the lamp successfully, thus you will see there’s a hotspot named like yeelink-light-ceiling*** in you wifi.

Yes, it seems you didn’t reset it correctly. The lamp will start to blink when the correct reset operation was detected.

Like i said, the lamp won’t resetting. I do exactly like the guide to reset- 2 sec on, 2 sec of - 5 times , but with no success

Like I said, you need to pay attention when the lamp start to blink. Just keep trying until the lamp start to blink.