Connection problem with yeelight bulb color e27 (connection timeout)

I cant connect to my yeelight bulb e27 color because of “connection timeout” problem.

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp by power on and off fives times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

And at last please use another phone to setup a hotspots with 4G network and try connect the bulb to it, I want to make sure if the bulb is ok. Thanks!

Hello Dingyichen,

i am having the same issue i have gone through all the steps. the lamp is not in my dhcp.
i still can’t connect to it as it always fails at 99%. i have attempted multiple times.
how would i “connect the bulb” to the 4g network?

very frustrated as i have spent a lot of time resetting and pairing to the app.


i had this issue and for me what solved it was to go into Iphone general settings search Mi Home app and confirm Local Network access was granted, this worked good