Xiaomi Desk Lamp can't connect to Wi-Fi

I’ve connected my other Xiaomi lamp (the Mi Bedside Lamp) using the official Android Yeelight application with absolutely no problems, but I can’t connect the Desk Lamp no matter what I’ve tried.

The process that I follow:

  1. Make sure that the lamp is connected to the power adapter (it turns on)
  2. Make sure that the device is added to the white list on my router
  3. Turn on the Yeelight application, select the Desk Lamp from the Add new device menu
  4. Click next, reset the device using the reset button on the bottom of the base of the lamp (the lamp blinked 5 times to confirm that it did successfully reset) as shown on the screen
  5. Click next, the app is searching for the device - it found the MAC address of the device so I choose it and click next again
  6. The app is searching for my Wi-Fi network, I type in the password and click next

Now the app is stuck on the “Updating connection status, just a sec…” indefinitely, it goes to 100%, connection times out and it asks me to try again.

What I’ve tried so far:

  1. Changing the network mode between:
  • 2.4GHz + 5GHz
  • 2.4GHz only
  • 5 GHz only
  1. Changing the security mode between:
  • no security
  • WPA-PSK/WPA2-PSK
  • WPA2-PSK
  1. Changing the network standard between:
  • 802.11 n
  • 802.11 g/n
  • 802.11 b/g/n
  1. Changing the channel width
  • 20 MHz
  • 20/40 MHz
  1. Changing the name of the network
  • only lowercase letters
  • only uppercase letters

I’ve returned the lamp to the seller and got a new one of the same model - the problem is still occurring.

I’ve also tried using a different application (Smart Home), deleting the other lamp from the app and router before connecting this one, using WPS, using a different phone (Samsung Galaxy S8, Samsung Galaxy S Plus, Sony Xperia Z3C) but nothing helped me so far.

I’ve seen on the forum that some people are asked for their Mi ID, so here it is: 1797738056

The lamp can only work with a router 2.4Ghz using WPA/WPA2 encryption method with a password.

Could you see the lamp in your DHCP list after connection failed?

And what about the ping result of "sg.ot.io.mi.com”、"ot.io.mi.com”、us.ot.io.mi.com” and de.ot.io.mi.com”?

I have tried that combination already (2.4 GHz only mode with WPA/WPA2 encryption enabled) and it didn’t connect.

As for the DHCP - I have reserved an IP address for the lamp’s MAC address in the pool, but it can’t connect to the router (it’s not being shown in the DHCP connected devices list).

And when it comes to pinging those servers:
sg.ot.io.mi.com [52.74.152.99] average = 273ms
ot.io.mi.com [124.251.57.12] average = 270ms
us.ot.io.mi.com [35.167.218.97] average = 205ms
de.ot.io.mi.com [18.194.20.12] average = 30ms

I’m using the German server, because it’s the closest one - previously I used the Singapore, before the German server was online. As far as I know all the domain addresses are properly resolved and are responding, changing the server didn’t help.

So this is the problem, if the lamp can’t connect to your router, the connection won’t be succeed.

Please use another phone to setup a hotspots with 4G network and try connect the bulb to it.

I’ve created a WiFi hotspot using another phone (Xiaomi Redmi 5A), using default network SSID (Redmi), WPA2 PSK security with a password and 2.4GHz mode.

Unfortunately the result was still the same - stuck on “Updating connection status, just a sec…” phase from 50% to 100%, then “Connection timed out”, even though the lamp did appear on “connected devices” list (as ESP_027720), with the correct MAC address (78:11:dc:02:77:20).

I’ve managed to connect the lamp to a WiFi hotspot created on my Galaxy S8, using Yeelight app installed on Xiaomi Redmi 5A (the other way around than the previous try). Then I’ve updated the lamp firmware, disconnected it from the hotspot network, and finally it successfully connected to my main WiFi network!

Solution: If you have a problem connecting to your router, first update the lamp firmware using another phone as a hotspot.

1 Like

I’ve tried all your solutions: i’va checked mi server, i’ve chaned google dns, i’ve make an hot spot via Huawei phone, but my lamp don’t connect animore…

one last detail: in both router, huawei hot spot and normal server wi fi, le lamp is connected…

Hi, I’ve tried all your solutions. Bat can’t connect the bedside lamp.
Servers are pinging all bat not “sg.ot.io.mi.com” i use germany. lamp connect to the wifi network recieved ip from my network i see lamp on may dhcp lease list, but initialising on aplikations don’t finishing.
What i can traing?
https://clip2net.com/s/40XSa6e
Clip2net_190410193133

I had the same problem. I have changed my WIFI setup and connected all my Yeelight Ceeling lights and RGB bulbs without a problem. When I tried to connect the Mijia Desk Light it failed.
I found out, that the problem is the SSID. My setup was SSID “FELD-IOT”. This failed.
When changing to “IOT” the lamp was able to connect. So it’s either the length or the dash “-” in the SSID.

@dingyichen: Could you please check, whether it is a firmware bug?

I solved this using another android phone.

@pax2011 You are right. I spend 4 hours to make it work with my Samsung S10e, without success.
Just read your message and tried my Mate9. What should I say, problem solved in 30 seconds.
Seems I need a chinese phone to connect chinese lamps to WIFI. Strange!!!

Thanks again for the solution!

Had the same problem with p30 pro than used and Xperia and It works

@jonofe @pax2011

Which app do you use, Yeelight or Mihome?

Mate 9 succeeded and Samsung S10e failed wit SSID “FELD-IOT”? This is weird.

And please have a check if you new phone have feature of can’t connect wifi that has no internet, seems your phone can’t connect to AP of the lamp.

I am facing the same issue, My bedside lamp 2 shows in the router’s DHCP client list and device connected list but it is not connecting to the app through wifi.

When I connect it through my phone’s hotspot it connects instantly.

Also this
And what about the ping result of "sg.ot.io.mi.com”、"ot.io.mi.com”、us.ot.io.mi.com
this results in a timeout.

Only this de.ot.io.mi.com” gives me

64 bytes from 18.197.235.166: icmp_seq=0 ttl=47 time=150.653 ms
64 bytes from 18.197.235.166: icmp_seq=1 ttl=47 time=149.558 ms
64 bytes from 18.197.235.166: icmp_seq=2 ttl=47 time=162.149 ms
64 bytes from 18.197.235.166: icmp_seq=3 ttl=47 time=148.938 ms
64 bytes from 18.197.235.166: icmp_seq=4 ttl=47 time=149.097 ms
64 bytes from 18.197.235.166: icmp_seq=5 ttl=47 time=149.769 ms
64 bytes from 18.197.235.166: icmp_seq=6 ttl=47 time=164.236 ms

Please help me in connecting it.
It did connect first time but when I moved the device to different location near router it is not connecting.