Yeelight 1S strip cant connect after firmware update

Hi there.

I purchased a Yeelight 10m lightstrip a couple days ago.

I set it up and it worked great. Then ~2 hours later the xiaomi app told me to update the firmware, so I clicked update. After the firmware updated the lightstrip could not connect to my wifi anymore and was offline in the app.

Since then I have rest the lightstrip multiple times (switch off, hold button, switch on, wait 5s), but cant get past the final step on the phone.

I am in Australia, and my xiaomi account is Singapore based. I have uninstalled and reinstalled the xiaomi app. I deleted the linked lightstrip in the app, and I can go through the steps to re-add it, but it fails at connecting to the network.

The Xiaomi app sees the light and I can input the set up the wifi network. Then the app goes to:

  1. Connecting to the lightstrip via bluetooth (success)
  2. Updating settings on the light strip (success)
  3. Connecting to network… Fails, says it cant connect to the wifi.

My modem is a Netcomm NF17ACV xDSL modem/wifi router.

With the modem I have tried:

  • Disabling the 5ghz wifi so only 2.4ghz is available
  • Changing the name of the wifi network
  • Changing the DNS server from (google) to (cloudflare)

I have tried connecting the lightstrip multiple times. It is about 4m away from the modem, with a clear line of sight.

If after failing to connect, I switch the lightstrip off then on again, the small indicator light goes from yellow to blue, but I can not see the lightstrip in the android app.

Can anyone help with this? Im not sure what to do next. It was working fine before the firmware update.

Here are my modems Wifi settings:

Here is what the app says when it has failed:

Here is what it says when you ‘View details’:

Ive tried connecting 20 times with no success. Can anyone help? There is a 3 year old post in Chinese with a solution, but I cant read it: Yeelight Strip Plus failed to connect to router after update - #14,来自 kevinnuke