Yeelight stopped working with Alexa suddenly.

Suddenly all of my lights stopped working with Alexa. I’ve tried removing them from Alexa and resetting them. However, now I am unable to link Yeelight with Alexa. I’m not sure what’s going on. Apparently many people are having this issue.


Having the same issue now. Integration has been working perfectly for 2 years and then all of a sudden, devices are unresponsive. Tried fixing the issue by redoing the whole process but can’t seem to link the account as well.

I checked the main website of yeelight but it seems the server is down.


Yep same problem for me. Lights work via the yeelight app and are connected but show as non responsive to Alexa app. Hopefully it’s just a server outage and is fixed quickly

Same here! Waiting for the fix! :raised_hands:t2:

Same issue here. Works fine on the Yeelight App but not via Alexa. Tried disabling the skill and re-enabling but keep getting error “We were unable to link Yeelight at this time”

Just an update: I just tried re-linking my account again and it is working fine now.

1 Like

Yep working again now. I didn’t delink or relink or anything, just came back up and works. Scary stuff if all the servers ever permanently go down, I have 16 of th
ese things.