Offline issue

To who suffering device offline issue,

Recently we received some feedbacks that your device shows offline in Yeelight and Mihome, I feel so sorry about that. Actually, there is a lots of things may cause device offline, such as network, router, backend etc., and the issue is different case by case. For the case of backend issue, we need co-work xiaomi backend engineer. And now we need your help to figure out what’s going on there. So could you provider the information below:

1、Which device do you have? And what’s the firmware version?
2、Which server do you connect to?
3、Please help confirm if the device shows offline both in Yeelight and Mihome.
4、If you have Amazon Alexa or Goole home, please help confirm if they can control the device when the device shows offline?
5、If the device shows offline, please have a try with “Turn All on/Off” in Yeelight to see if it works.
6、Please confirm if the device still connected to your router(You can check the DHCP list)?
7、Please confirm if your device could come back online after power cycle in two minutes?
8、What is the type of router?
9、Have you tried with setuping a hotspots with another phone, and connect your bulb to it to see what’s going on?

If you have the issue, we can contact with WeChat to do some live debugging, you can connect me with my WeChat ID: “Andydingding”.

Much appreciate with your help!


1 Like
  1. Yeelight Color LED bulb;
  2. US server (but I have also tried with the other two, same problem);
  3. Yes, the bulb is offline in both apps ;
  4. I have tried with Google Assistant and it says that bulb is not connected ;
  5. It doesn’t work ;
  6. When it goes offline it is not visible in the router settings;
  7. It will come back after it is unplugged for a few minutes. But it goes offline very quickly.

If you need any more info please let me know.

And have you updated to the latest firmware for you bulb?

  1. Xiaomi Router Mini;
  2. I have tried with a hotspot and with a different router, same problem;
  3. Yes, the bulb is on the latest firmware available.

Exactly the same issue here.

My router is Asus RT-AC66U

It was working perfectly fine until 2 days ago where all my Yeelight didnt work. My entire house uses Yeelight and sensor. Please help to fix it.Always show as offline. All Yeelight bulb is also on the latest firmware. There was no firmware update in the pass few days anyway. I connected to Mainland china always, now any server also detect as offline.

Maybe I can provide more info since I use all Xiaomi products. All the below devices are offline:

  1. Yeelight bulb
  2. Yee color light bulb
  3. Wireless switch
  4. Motion sensors
  5. Gateway V2
  6. Mi humidfier
  7. Mi door sensor
  8. Mi temperature and humidity sensor

Practically, everything goes offline and only the Yi CCTV is working.

I do see all the devices in my router menu. Just all show offline in Mihome app.

  1. Yeelight Ceiling Light , firmware up to date (can’t see the number because its offline.
  2. China Server
  3. Yes, Mi Home and Yeelight don’t work
  4. No, because its China Server
  5. Does not work
  6. Already reseted the light so it must have wifi connection
  7. Now it works, will report if it shuts down again

Could you ping these devices? Please also provide your Mi account and we will take a look at the log.

Yes, I can ping my devices. My ID is 319566771

I have no idea what went wrong, lucky I still can use manual switch to control the lights. I will try to reset my entire network next. Factory default the router and resetup everything, Hope it works. Else I am out of idea.

I went for my vacation and when I got back, everything wasnt working. During this period of time when I was on vacation, there is nobody in my house.

Found the problem. It is my Asus router giving me issues. Nothing is wrong with the app. Its all due to my Asus Router having issues,

Could you let us know what’s the problem with your Router?

1、Yeelight strip, 1.2.4_16
3、Shows as offline in Yeelight app even when light strip is on; app controls do not work
4、Through iPhone app only
5、Does not work
6、Yes still connected
7、Yes, reconnects
8、Asus RT N12

Not able to update the firmware through the app

MI ID: 1770788917

  1. Yeelight lightstrip, 1.2.4_16
  2. US
  3. Shows as offline in Yeelight app even when lightstrip is on; app controls don’t work
  4. Through Android app only
  5. Does not work from 6 days
  6. Yes still connected
  7. Yes, reconnects and ping
  8. Asus RT-AC66U
  9. Previous was OK on Note 8. I try now in Note 3.

MI ID: 1755673913

All was OK 10 days ago. Last firmware updated 10 days ago. And suddenly 6 days ago in the morning appearing offline. I try reset many times, I did reinstall software on other phones. Then I try all the servers US, SG, China. I did fixed band and fixed IP on router. But nothing changed. Only what I can PING it the lightstrip.

Any suggestion ?


For the moment I solved my problem. I moved the Yeelight lightstrip in Guest Network on my router where the Yeelight cannot access my internal network. It is possible the firewall from my router to be in conflict with Yeelight lightstrip and reject it or something else.

Maybe this solution can help other customers if their router accest Guest Network.


Hi Xmacix,

Thanks for your feedback!

Could you please provide following information to help us narrow down the root cause?

  1. How frequently your lightstrip got offline before?
  2. Do you mean after you move your lightstirp to Guest Network, everything works fine?
  3. What devices connected to the same router?

The story is that:

I received in 19.12.2017 the package with 2 pcs Yeelight lightstrip. I install it one pcs on US server and instantly I did firmware update. After that I play with it, I did create scene, then I connect it to Google Home Assistant. In the next day I see it offline 2-3 times but just for 15 seconds (nothing important). All was OK until in 22.12.2017 in the morning from when remain only offline. I try 2 days from time to time and was only offline. And then I did delete it and I cannot add it again for 5 days until I connect it on Guest Network. I don’t remember if I restart router or not, just before to be continuous offline.

Answers are:

  1. 2-3 times for 15 seconds;
  2. Yes, everything as before (except from the wear smartwach, but that did not work neither before, I think you know that)
  3. Are a lot of devices: desktop, 2 laptops, 3 IP cameras, PS4, printer, NAS, switch, smart tv, router extender, 2 smart plugs, smartwatch, thermostat gateway. All of them are on fixed IP on router.

The second lightstrip is still in the box untouched :gift:.


I got the same router. could you please share your solution. Thanks

I don’t think there is anything to do with guest network.

Could you try again with previous network and check if it could be connected?

I tryed and now it’s OK with main network. But why ? What did you do ?

It works perfect from the first try.

Thank you ! :thumbsup:


We did nothing. Someone else reported similar issue, we didn’t reproduce that in our lab.

Please keep eye on this case, once it happened again, please let me know before you change anything.