4 w3 bulbs stopped working (UPDATED)

I have 4 W3 multicolor bulbs that worked perfectly until a few days ago.
2 of the bulbs lost connection completely. Attempted to reconnect them but would not. Tried resetting multiple times, tried changing DNS and even tried changing servers as well as different phones…among many other things. Nothing I found on any sites or forums helped.
During my attempts to reconnect the 2 bulbs that weren’t working, the 2 working bulbs failed to connect.
I once again tried everything including updating the firmware. Nothing
However, I could connect all 4 bulbs IF I did the process within one foot of the router. So I connected all bulbs and placed them in the devices they had previously worked. 2 we’re within 10 feet of the router…and none appeared in the Device List on the app after installing and turning them on. None. So I once again moved the bulbs back to within a foot of the router, added them all, turned them off and then reinstalled them one by one into the device I used to connect them (a simple lamp) to make sure they were still connected in the app and they were. But as soon as I in installed them where they need to be, one by one…none showed in the Device List again.
My router has excellent coverage throughout my home, especially on a 2.4 connection.
DNS changes don’t help.
Router security configuration changes don’t help.
Network Used/Pass does not have any weird characters
Firmware update did not work.
Changing servers did not help.
Once again no workarounds or solutions worked.
My network strength is amazing everywhere I had the bulbs previously installed when they did work.
The bulbs do connect and work but only when placed next to the router.
This has made all 4 bulbs worthless.
If there is a solution that is different than all the currently available solutions…and not tell me my wifi signal is somehow weak or that changing DNS settings is the magic cure, I would be happy to entertain it before I throw these bulbs against a wall.

I figured out the issue yesterday.
It appears that a set of Govee Glide lights I purchased and installed recently was the problem. As it turns out the Govee Glides, when active and connected to WiFi, make it impossible to activate/connect the YeeLights (Connection Timeout via app) if they are all in close proximity. Once I disabled the Govee lights I was able to configure the YeeLights once again. As of now, all 4 YeeLights and the Govee Glides function…
However, it is possible this is just a temporary solution and the Govee lights may cause another connection issue in the future.
I’ll just wait and see if that is the case.

Although the Govee Glides seemed to be the issue 2 days ago, they are not as of yesterday. Now I can connect 2 and sometimes 3 Yeelight bulbs. However the 4th will not fulfill the connection process (app connection > fast blink and thats it). And if it does connect, it only works within the Yeelight app and will not function outside of it (Google Home or any other automation service I use).
Very disappointed.

How many WiFi devices are there in your home?

The same number as when the bulbs worked perfectly…20 give or take 2. I have zero issues with the rest of my devices. My router is a TPLink Archer A20 (ac4000).
Also now only 2 lights will connect for use with Google Home or another service called Lumiastream. A 3rd light connects to the YeeLight app but nothing beyond that.And the 4th Bulb refuses all attempts at connection to even the YeeLight app.