99% Timed Out— I've tried everything!

Alright here it goes, I know you’ve seen this before— I’ve tried to connect my bulb but it hits 99% and times out every time! The strangest thing is that I have 3 working bulbs in our apartment, and don’t understand why these won’t work.

They are Smart LED Bulb W3 (E26)

I’ve tried the following:

  • Resetting the bulb
  • Renaming Wifi name and password to exclude special characters
  • Changing DNS Servers to and as secondary
  • Making sure I’m connected to a 2.4Ghz and not 5Ghz Wifi
  • Making sure my app is up to date (Yeelight app)
  • Making sure my router is up to date

Any help is appreciated. I really like the Yeelights that I have, the working ones, and would really like to continue using the products. If I can’t find a way to make these work, I’ll have to try another product ($$$). :frowning:

Looking forward to any and all advice!

Please provide your Xiaomi account and login server. Another way to try is to switch to another network, or use your mobile phone to open a hotspot to see if you can successfully access the network. If you can successfully access the network, upgrade the firmware first, and then try to use the original network