Yeelight lightstrip not connecting to wifi

I have an original yeelight lightstrip. When I use to yeelight app (I can’t use the Mi app as the light strip is too old) I go through the steps (reset the strip, put in my wifi details, connect to the strips wifi) and and it stays on 0% when the light strip attempts to connect to my home wifi and configure itself.

Are there any clues to troubleshoot this? I have seen other posts on this forum but no solutions.

I am using Deco mesh network for my wifi. I have tried disabling 5ghz and fast roaming is off. It’s as vanilla as I can make it. Weirdly, I have 2 other strips working well but admittedly I haven’t tried pairing those again since I have had the mesh network.

I am logged in to Asia/Oceania region in the yeelight app. Could that make a difference?

Hello. Did you reset the light belt and confirm that it was reset successfully? Is there a blinking state after the reset? The firmware of the server corresponding to the overseas and mainland products will be different, and the overseas servers are basically the same

Thanks for the reply

Yes, I have 3 blinking orange lights so reset was successful. What exactly do you mean about firmware versions though? So what I will do is log into mainland China and see if I can add the yeelight to that server….

Hello, firmware version is a product update, a new version of the program, fixes some known problems, and updates some features

I have another light, a yeelight bulb, and it exhibits the same issue. Could this be an issue with the network?

From my experience. If your router hosting bunch of WiFi in the same SSID. But with different withband or password. Sometimes phones, at least Android phones, got automatically disconnected the wifi which should be use to sending commands into the lamp which the lamp set up by itself, and switch the connection into your router wifi. Which leave the lamp have no clue of what the next command is.

I suggest that you can try to set up an open wifi. After the lampve been setting to that wifi, then bring the wifi password back. and reset the lamp again.

Meanwhile, while your phones talking to your lamp, make sure the “smart” phone won’t switch from the hotspot that the lamp sending out to your home router in its wisdom.

Android phones comes with a smart wifi or some kind of feature like that. If phone detect that the connected wifi have no internet access, it will switch to a one that can. Be aware. But no worries. If anything interpret the process it won’t damage the firmware. Just reset the lamp again and again

1 Like

Hello, network environment does affect device access, you can change the wifi add to try