W3 Color Bulb won't connect after reset

I moved to a new place with a new Internet connection. I was able to easily connect my 1S bulb and my lightstrip by resetting them. But my W3 color bulb will not connect no matter what I do. I’ve tried resetting it twice and every time I try to connect it, I get: “device disconnected. Keep phone close to device and try again”. I’m sitting right next to the device. A speed test shows that my internet speed is very fast. The other bulb (1s) is literally in the same fixture, so it’s not a location issue. What do I do next?

When you reset the W3 color bulb,can you find the wifi of the W3 color bulb in your wifi list of mobile phone?

Yes, I can see the bulb listed under wifi. During the set up process, it asks if I want to allow connecting the bulb wifi, and I say yes. That goes ok, but when the set up reaches 49%, I always get the “device disconnected” error.

I’ve also tried disabling 5GHz on my router, so only 2.4GHz is available, but it still doesn’t work.

Maybe you can try to connect another wifi,for example,the mobile phone hotspot.Let’s see if the problem lies in the product

I have the exact same problem which I can’t solve. Did you succeed ?

Up, i have the same problem pls do something