Alexa won't discover my Yeelight bulbs

I recently bought 6 Yeelight bulbs - 4 colour and 2 white only.

I bought them on the basis that Alexa was supported. When they arrived, I installed the app and they all configured fine. I then installed the Yeelight alexa skill but Alexa won’t discover any of the bulbs. All firmsware was up to date.

I gave up for a few weeks and notices that the Yeelight App has recently been update.

I also noticed a new server in USA (I’m UK based). I switched over from the Singapore to USA server and tried once more to get Alexa to discover the bulbs but this still proved unsuccessful.

Why is this so difficult? Why are some Yeelight able to configure their devices with no problem, yet I have 6 Yeelight bulbs and not one of them will co-operate with Alexa…

That’s very strange, Alexa has had no issues finding any of my bulbs. Have you tried the usual clearing of data etc from the Alexa App?

Another option might be to try using to set them up and make sure the Yeelight skill is definitely installed. There is also the option on the web version to forget all home devices, which might be useful if you have anything else registered and something funny is going on.

Tried all of the above. I have numerous other smart devices - all Hive stuff which work without issues.

you need to use Singapore or US server.

I’ve tried both servers. Originally connected to the Singapore server with no Alexa connectivity. Then, after the recent update, I noticed the US server so I connected to that and still no Alexa connectivity.

Yeelight app can show the bulbs and control them, right? If yes, could you try IFTTT and see if it can discover your bulbs?

The bulbs can be controlled via the Yeelight app using both the Singapore and USA servers with no problems

Do you know IFTTT, please create one applet and try.

Hi. Sorry for the late reply. I thought I’d wait a few months and see if any of the updates on either Xiaomi or Alexa have made any difference. Still nothing. Yes. I use IFTTT all the time, no, I’m not going to sit there and say "Alexa , trigger light on’ and then 5 minutes before a light switches on!! Also, IFTTT doesn’t show a list of the Yeelight devices, despite being connected to my Xiaomi account. I imagine these bulbs are fantastic, but I can’t get the to integrate with Alexa which was be whole point of getting them. Having to get my phone out all the time just to switch in a light make it an inconvenience - totally the opposite of what a smart home is about!

1 Like

If IFTTT could find your bulbs, Alexa can also find them, they are sharing the same logic. You can let us know your Xiaomi ID and we can help you check the log.

Hi WeiWei. Just to clarify - IFTTT does not detect these lights despite having the Yeelight applet activated.

MI ID: 1703233666


hi,we had searched your record use you MI ID you give, find nothing. Do you give the right MI ID?Could you check your MI ID again?

Hi, i didn’t found your request log in the backend, did you encounter an error page in the process?

Alexa user guide:
1、Left menu click Integration.
2、Click Amazon Alexa
3、Link Yeelight with Amazon Alexa

Case of we didn’t find your MI ID,it’s mostly because you hadn’t login your XIAOMI account when you use Alexa and IFTTT.You can find the way to connect your XIAOMI account with Alexa by below steps:

Yeelight skill was enabled and account was linked ages ago. I often unlink and relink to try and get it all working. There’s no problem with the account linking. Strange that you’d have no logs for the account.

No error messages at all - none whatsover. The only indication that there is any problem is that the lights simply aren’t found when I ‘add devices’ from the Alxa app, and no lights are listed in the IFTTT app.

Think about that, maybe you have two XIAOMI accounts,and you login Yeelight App with the first one but connect Alexa with the second one?Because, it’s impossible that you had connected you XIAOMI account but we didn’t log it.

I think you might be right!

When I unlink and relink, the MI ID is different. When I switch accounts, it this number (which is different to the one I use on the Yeelight app) into my email address but when I try and switch accounts, and enter the MI ID as a login, it won’t accept it and instead tries to use turn it into my phone number

I’ve logged out and logged in to Yeelight using my email address account which now matches the ID that Alexa was using - I’m not sure how this happened but maybe as I already use a Xaiomi phone, it was already pre-assigned a MI ID which wasn’t linked to my email address?

Anyway - will try this all out later when I get home!! Finger crossed :slight_smile: