YLDL01YL no wifi connection

I recently bought a Yeelight Meteorite YLDL01YL light and installed it. After resetting it by turning it off and on 5 times, it starts breathing for a few times, turns off shortly and back on with default settings, but I’m not able to connect it to the Yeelight App. I tried it several times with different Android devices and multiple routers, all on 2.4 Ghz with WPA2 protection. I also have another Yeelight, that is connected the same way to the same router and the same mobile device and app.

I’m also not able to see any Wifi Network from the lamp itself after reset, I looked at it with a Wifi analyzer app. Also I tried to setup miio_default network with the 0x…. WPA2 key on 2.4 Ghz, but the lamp did not connect to it, so it doesn’t seem to be in factory mode.

From my other yeelight I also got a bluetooth remote which I was able to connect to the new YLDL01YL, there I could also change the light settings and the lamp keeps those even after power off, so at least bluetooth connection is working for the lamp.

Could you please tell me, how to solve the wifi issue and connect it to the Yeelight app?

Thank you!