Google home "could not reach Yeelight. please try again'

I recently added some extra bulbs to my Yeelight account. I tried to get Google home to detect the extra bulbs but no matter what I did it wouldn’t detect the extra bulbs. In desperation I unlinked Yeelight from Google home and tried to re-link it again.

When trying to re-link Yeelight to Google home I sign in with my Xaiomi account and click ‘agree and link’ it then says: Google home "could not reach yeelight. please try again’

I’ve tried multiple times. I’ve also tried doing it from the Yeelight app to tell it to link with Google home but the same thing happens.

I know the account is correct, and I’m using the Singapore server.

Any ideas on how to fix this?

I did the same as you. Now my lights are not showing up at all in Google Home. :frowning:

at least I am not alone now :slight_smile:

Yeelight team is working on it. We are sorry about the inconvenience caused.

Service has been recovered. Please try and let us know.

I can confirm that it is all working fine again now. Thanks for fixing it

Hello, I’m facing the same issue during the linking process to Google Home. Error: could not reach yeelight, please try again later.

Help @coasterli

Hi, I’m having the same problem now. Please help