Integration with Alexa in iOS

Dear users,

I have three Yeelight bulbs here. They are working well and they are already configured in Yeelight app (also did in Mi Home before, sucessfully). However, I tried everything but I was not able to integrate it with Alexa. I followed all steps from the website, but Alexa does not recognise my bulbs. What should I do, please? Can You give me some help?

I’ll give you some infos about my bulbs:
Smart LED bulb 1S (Color)
Model: YLDP12YL

I am in Brazil right now (I saw some people changing servers and I don’t know if it matters on my case).

I thank you all, for your attention.

Have a good day!

Hello, the model of the Light Bulb, the wi-fi that the light emits when you plug it into the Internet.
Or give us the MI account number

1 Like

Hi! Here follows the information you demanded:


Hi. I did a little background check, and your lamp supports Alexa。
There is a problem to make sure your firmware version number is up to date?
If you’re up to date, try this: unstrap three bulbs, add them one by one, Scan Alexa for each light bulb, see if it can be detected, and don’t add three lights at once. Try this method.

1 Like

The problem may be that the model in the red box may or may not have a value, so the device can not be found

1 Like

Thank you for your help. I guess it is up to date. After connecting the Bulb to Yeelight app, a window asking for update shows up.

I’ve just tried to add a single bulb to Yeelight app and then to connect the bulb to Alexa, but it does not work. Same problem again…

So what to it mean? The bulb cannot be connected to alexa?

Send me the yeelight APP account

1 Like

Hold on. I’ll run a test on a lamp of the same size

1 Like

My Yeelight app account is 6489391280

Wait a minute, this lamp supports Alexa. Let’s test it out. I’ll get back to you

1 Like







Hello, take a look at the Alexa steps, our colleagues tested it, you can enter the Alexa, you try again

1 Like

Hello! Thank you so much for your help!

I was doing doing the right steps, but for some reason, despite using the same phone number, two different Yeelight accounts were created. When I fixed it (using the same account in Yeelight app and Alexa) the connection worked!

Thank you again!

:+1: :+1: :+1: :+1: