Yeelight LED Bulb Not Connecting to Google Home

I just got the Yeelight Smart LED Bulb W3 and connected it to the Yeelight app. I’m trying to connect it with Google Home, but every time I go through the link process on the Google Home app I get a small notification that “yeelight is linked” and that’s it. I don’t get the option to add the device to my home or room. I’ve seen this issue on the forum, but haven’t found a solution yet. Any help would be greatly appreciated!

Also, I was able to connect three Candelabra e12 lightbulbs to Google Home through the Smart Life App. So I know Google Home is working with another app, just can’t seem to get it to work with Yeelight.

1 Like

I’m on the North America server btw.

Same here since yesterday. EU server. All yeelight products just dissapeared from google home, but are visible and working in Yeelight app and in Mi Home app.

facing same issue which started today. Singapore server. Bought 3 new Yeelight W3 and after setting it up on the Yeelight app, found that even my existing one was showing Offline and new ones are not detected by my Google Home.

Just added a mi light strip to my existing 3 bulbs and was trying to add to Google Home …

After readded yeelight account , only mi strip came up as 1 device on Google Home …

Reset everything thinking mi strip causing issue …but I was wrong … seems like a global issue that bulbs going undetected on Google .

Will wait and see …

Glad to hear it’s not just me! Hopefully they release a solution soon. And so my watch begins.

same here,but i need connect xiaodu speaker

Seems reasonable to believe the issue is related to Yeelight/ Mi Home connection to Google Home. I’ve tried resetting the bulbs and my Google hub, changing and creating new accounts for both Google and Yeelight, tried linking to Mi Home instead of Yeelight, changing server region; basically nothing works. The issue now is that even though my Yeelight/ Mi Home account is “Added to my Google Home”, I still don’t see it in my “Linked Devices” list.

All my bulbs came back today after relinking the yeelight app . Before this just my new strip apperead .

I believe there is some issue with yeelight and google home previously .