Yeelight IFTTT Service disconnect every day


#1

Hello,

I am having quite a serious issue where my Yeelight services within IFTTT will disconnect every single day at a specific time (or sometimes within an hour or so of it). I will reconnect the service and everything would work normally again, but then out of nowhere, at that specific time (01:58 in the morning or somewhere close to that time) it will disconnect on its own. I’ve read some topics here where you suggest that maybe the lease has expired with the router. However, even when the service within IFTTT disconnected, I can still control the bulbs with the Yeelight app on my phone, so the bulbs are still connected to the internet and your server normally.

Is there something that you can suggest or do to resolve this please? I rely on the IFTTT applets to run these bulbs I use, and if it disconnects all the time, it becomes pretty annoying. Please help.

I’ve attached a few screenshots from my IFTTT app to show you the errors that I get every day. If you need me to provide additional info, please feel free to let me know. Thank you.


#2

Hi!
I have similar issue!
Its very annoying :(:triumph:
Your problem solved?
Or anyone else can solve it?
Thanks!


#3

Same here, with the color bulb. The only workaround to this problem is to go in the yeelight service and click on edit connection end redo the sync. Is very annoying since I have to do this everyday, please fix that or explain the solution. Thank you


#4

We will look into it.

@Aquariuz23

Sorry, we missed your feedback before.


#5

Do you have two ifttt account but attach to one XIAOMI account,or you have logined IFTTT with two mobile device by one XIAOMI account?Maybe it will make IFTTT try to refresh access token two times. If not ,please give me your XIAOMI ID ,i will check the request logs.


#6

Same thing happens to me everyday, don’t know exact time.
I have single account connected with xiaomi account.


#7

The ID should be 1682954207, and no, single account synced. Everyday, circa 11pm/12am central Europe the service disconnects, dunno if this is based on my last re-login time in IFTTT or if this happens everyday at the same time, no matters when I do sync again the service. Sorry for bad English


#8

@P3ppemani @pszafer We are looking at it,please wait few days.


#9

Today happened between now and 1 hour and an half ago, when I launched last yeelight Applet in IFTTT


#10

@P3ppemani. Hi,we had searched the log,and find you login and authorization XIAOMI one time between 1.23 to 1.24, isn’t it?If you login more times,please tell me.
And when you are login ,do you remember you had selected the authorization options?Because we find one record said that you were not authorized us to get your XIAOMI information.


#11

I logged in aroind 9.45 pm central Europe time. I don’t remember that thing about authorization, but are you asking about my first time login or the one I did yesterday?


#12

I mean the one you did yesterday. How many time you logged in yesterday?


#13

I think one around 12 am and one around 10 pm


#14

I just re-logged and have given the authorization again


#15

Hi @P3ppemani, We searched logs and find IFTTT request us to refresh your access token many times,even your access token didn’t expired.I will email to IFTTT.


#16

Still having the problem =(


#17

Yes, i’m sorry, it’s still. We are contacting to IFTTT,and waiting for they reply.You know it need time for email to them and waiting for the reply, especially we are in different timezone.


#18

@P3ppemani IFTTT had reply to me,they were working to fix this problem.


#19

@P3ppemani We and IFTTT just checked and find your account is indeed connected to two IFTTT accounts, you might have forgotten about the other account (two IFTTT usernames: “giuseppemaniscalco93” and “giuseppemaniscalco931”).
Please try to check the two account, and disconnect your XIAOMI account in one.


#20

Is this issue solved? I still have disconnect problem. I have to reconnect every day if I want IFTT to work…


Yeelight IFTTT not working