Google Home can’t detect Yeelight Multicolor M2 Bulb

I’ve just bought the Yeelight Multicolor M2 LED bulb. Note, I don’t have any Hub or any other Google Home devices, I only have this bulb. The Google Home app can’t detect the bulb. I’ve read everywhere that you don’t need a hub for the bulb… Why is Google Home not detecting the bulb?

You need a Google Hub.
Here is how to setup your bulb.
https://en.yeelight.com/product/1273.html

I don’t have Google Nest. All I have is the bulb and an my iPhone. Can I use the smart bulb from my phone without a nest?

yeelight updated the firmware and disabled wan control of the bulb, this company is not to be trusted, return the product as faulty and dont buy any more yeelight products

There is an Yeelight app in the store, to control the bulb, without a hub.
https://apps.apple.com/de/app/yeelight/id977125608

I’ve tried that already but the Yeelight wifi does not appear. And I’ve already tried to change server, Power internet security and all of that but doesn’t work. The bulb does show the different colors but the wifi does not appear. I’ve tried with Android and iPhone.

Assuming you have a WiFi router, the bulb and an iPhone,
with the Yeelight app installed:

Temporary disable 5GHz in the router.
Make sure your phone is connected to the Wifi, not the mobile net.
Uninstall the app and reinstall it.
Grant all permissions.
Log into your Yeelight account.
Reset the bulb, to bring it into paring mode.
Tab on +, to add a new device.
Select your bulb.
Follow the instructions and (only if asked) connect your iPhone to the temporary Yeelight WiFi.
Your bulb should appear in the app, and should be controllable.

If not, ask a friend for help, or return the bulb.

@Spakkaps
Not exactly right.
Only Mi branded bulbs and lamps lost LAN-Control,forced by Mi.
Yeelight branded bulbs and lamps still have LAN-Control.

So much misinformation… :slight_smile:

first of all LAN control has nothing to do with this bulb. Second, you don’t need Hub for 99% of Yeelight bulbs, they’re mostly Wi-fi. Thrid, this bulb is not typical YL bulb but Google Home only bulb. That means you need Google home device (Nest). you can’t use it without Nest device.

I think you are correct, because I have already tried everything that the others have suggested and it just doesn’t work. Thank you.

Rubbish, I have many yeelight bulbs, everyone I updated now no longer works, the ones I did not update work perfectly

Do you have M2? He asked about M2, which is Bluetooth and connects only to Google Home!!!