Yeelight ceiling light just died

hi there
my yeelight ceiling light just stopped working. it wont turn on, i can’t connect to it. i bought it two months ago, is there a way to reset it or something?
thanks for the help

Reset it by turning on and off five times.

i’ve tried it several times. didn’t work. i’ve tried reinstalling it. didn’t work

Have you updated the firmware ever?

yes a few days before it died

could you contact your retailer for a replacement?

Had your problem some solution? I have the same trouble with a New Light

Please provider your Mi ID, we will have a look at it.


It seems you have the latest firmware. When was your light died? Where did you buy it?

Thanks, I’ve bought it by Gearbest. This week. It worked only one day - online, dimmer, all ok. Then I switched it off by wall switch and next morning it was offline and impossible to switch on. After 24 hours, yesterday, it worked for some hours. Now dead and offline.

I have the same problem …
I would be happy if you can fix my problem too.
My mi id: 1775381475


Have added you in the list, please update the firmware of your ceiling lamp and have a try.

I have not done anything yet, but now the lamp is working. I turned it off and turned it on several times. Thank you very much!
I wanted to ask if I should do something?
Second, what server should I be on? Because I changed the server I was in, and now the lamps are not connected to me in the app.

I am having a similiar problem with my RGB Bulb, wich server are you on? I am actually on the US server and is not working :triumph:

Device datas are separate with different servers, so you can’t see your lamps in the application after you change the server. And if you want to use lamps in the new server, you need reset the lamp and reconnect it.

1 Like

The issue occurs only when device is connected to servers out of China mainland.
Which server are you on now?
Anyway, recent update enhanced network stability; it’s always recommended to go for the new firmware versions.

My lamp is on china mainland server.
And the application says that is the latest version of firmware…
An hour or so ago this was the last time I checked the lamp and she worked. Thank you for your excellent service and your great help!

I returned to the china mainland server, and found my lamps.
Thank you!!

The lamp worked for a few hours and now it does not work again…
what to do? … :disappointed_relieved:

The lamp worked for a few hours and now it does not work again…
what to do? … :disappointed_relieved:
This is the third time that she get off…