Mi gateway on Singapore server

Free days ago, MiHome app upgraded to vet 5.0.1.

And today I just give it a try, switching my locale to Singapore.
And boom, all MiHome products are supporting Singapore server!

I am overwhelmed, it’s time for shopping !!


all i see are cameras
no switches

edited: oh its a big image
wait which singapore server?
the US(singapore) or
just singapore

can you share the apk

You need to go into your settings and fully clear the cache and everything. Singapore then started to show a lot more products. Tried to register my gateway before clearing everything, and it didn’t work (timeout on wireless connection), but I’ll try it tomorrow and get back to you all.

has anyone tested this?
we can have everything on singapore server now which means that yeelights can also support ifttt?

yeelight has already been supported by ifttt …only xiaomi’s product dont

yeah i know that, the problem was that if you wanted to use yeelights with xiaomi’s ecosystem you have to use Mainland China for them which stopped the IFTTT from working.
if xiaomi’s ecosystem can actually work on Singapore’s server now, it means that we can also have IFTTT back for the bulbs

@mokchuzhen how did you manage to get 5.0.1? The current build for Android is 4.2.5, and iOS is 4.0

I tested this in both for Singapore, and I can’t see any updates.

It’s a very good news !!!
As PrimeTeDev say, we will can use xiaomi’s ecosystem and IFTTT with Yeelight.

I’m on Android and my version of Mi Home is 4.3.11.

Here they are talking about 5.0.1 :

Mine says 4.3.15 in the app but play store says its 4.2.5. I think, 4.3.XX might internal build code.
However, this still doesn’t work for me.

Maybe, version 5 has a limited release so we should hopefully see this soon.

anyone wanna be a test subject


but its 5.0 tho

i did but revert back to 4.3.15 due to the my device view didnt have a grid view

Dear all,
I am sorry that I can’t try now as I am on a work trip for a week.
I guess the reason why I got it is because I was previously on China server which I didn’t link other Mihome products with Yeelight.

Mihome update is not from Google Play, it is from the app setting itself.

Even the products are in Singapore server now, but to he honest, it is still lacking of very interesting features in China server, which is Automation.

Sorry, I don’t have the apk.
The plug is there actually, you need to click into the picture. It is a long screen shot.

New automation rules but only available in China server.

I sent an email to Xiaomi about 10 days ago asking exactly this (to support Singapore server for gateway) and they answered a few days ago that the department responsible is taking a look at this (most probably many people sent similar emails not only me), but if the sensors are not supported there is no meaning :frowning: i hope all the sensors (switches, humidity, body etc) will be supported eventually (and not in a few years…)

The sensors are in the list but I am not sure whether they are working or not.

Thats great… if someone gives it a try, please give some feedback, i unfortunately have TOO many sensors and lamps to transfer them in Singapore server without being sure that they will work

Now i saw that it was a bigger picture in the first post (i also thought that only a few products are supported)
Oh what the hell… i will give it a try on weekend.

Is the US Singapore and Singapore the same thing? (support the same products)? what is best for Europe?

I also got up all devices on US Singapore server now! You must uninstall the app and then reinstall it from playstore. When you log in choose US Singapore server and do not change the language to English! Use “Default” as language setting and you will be able to see all devices just like the print screen in the top post. I don’t have any Mihome gateway so i can’t try if it works with Google Home. I have ordered one but I haven’t got it yet. Can someone please try and report back here?

It looks like this:

I’m back. A few issues but better.
+gateway now connects
+automation kind of connect to the gateway (not really though)


  • no automation settings for switches, cubes etc

So it’s still a bit useless. Have switched back to china for now…