Exit factory mode

Could you help me fix my light bulb ?
I bought a mi smart led bulb warm white model : XMBGDP01YLK
It lights up and then flashes, blinks.

I try the 5 times on/off method : doesn’t work.
I am pretty sure it’s factory mode because I have another light bulb that works perfectly.

Could you give me the correct hostpot name and password ?

I tried : miio_default and password :0x82562647
I tried the factory apk but seems to be old and outdated, doesn’t work.

Thank you very much !!


Hi, few months ago. I upgrade the factory apk. Try the apk again.


Hi @_guofeng , Many thanks for your reply. I tried the app you sent me. The app allows me to see an IP address however I was not able to fix the problem when clicking on Manual fix. I configured the hotspot as asked (miio_default with the right password : 0x82562647). The lamp does not connect to this hotspot and keeps blinking continuously. I don’t know how to get the lamp configured correctly and what I am doing wrong. Thanks again for your kind help.

First, make sure the bulb is in factory mode.

Reset the lamp by power on and off 5 times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list?

And what’s your android system version? We will check it.

Hi, I tried to reset the lamp 5 times then used my phone to see available Wifi signals named yeelink-light *** . No signal named as that was seen. I used a samsung S8 and A70 (both Android version 9 ) to do the test. In fact, the lamp blinks continuously since I connect it. I never succeeded seeing it not blinking even after the 5 time reset or the manual fix using the toolbox app you sent me. The lamp does not connect neither to the miio_default hotspot, I created on my phone. I have not only one lamp having that behavior but multiple ones which makes me thinking I am missing something to get the lamp working normally. Thanks again for your help.

I will do a test on Android 9 phone tomorrow. Please wait My news. Thanks for your patience.

Hi, I do a test on Mi Android 9 phone. And it works well. Could it be that your light bulb is broken?

Hi @_guofeng . As you said, I think as well the bulb is getting something wrong. In fact, I bought multiple ones (5 in total), all from the same batch (June 20) that show exactly the same problem like if they could not get a factory reset.
Thanks again for your help . It is very kind of you

I face with the same thing on 1s white version. Keep blinking and can’t and stuck in adding the device.