Bulbs randomly "No Response" in HomeKit and "Offline" in Yeelight APP

Dear Yeelight,

Momentarily we have two led bulbs, one YLDP22YL and one YLDP12YL. Randomly, and never at the same time, they loose connection with HomeKit.

When this happens, the status is “No Response”, within the Yeelight APP the status is then “offline”. Also I cannot ping the bulb anymore when this happens.

The only solution (workaround), seems to be a power cycle.

Since this behavior occurs several times a week (and always when you are not at home) is getting quite annoying. And thereby making home automation useless. The current firmware is 2.0.6_0013.

Good to mention is that we have other WiFi only HomeKit accessories that doesn’t have any problems like this.

So dear Yeelight, do you have a fix or new firmware to solve this issue for us?

Kind regards,

Vincent

I have the same issue. Yeelight app losing all lights every a week. For me what helped was router restart (so that they have to refresh their wifi connection). Because of that I’ve sheduled automatic restarts in my router every night and that fixes the issue but is more of a workaround.

Thanks for sharing te workaround!! I’ll give it a try. Hopefully Yeelight will come up with a fix, but hopefully this trick will also work for me. I’ll let you know :slight_smile:

The workaround seems to do the job, until I lost connection one time to one of the bulbs. So hopefully Yeelight wil seed new firmware to solve this issue. I found more people with similar issues with these types of bulbs. To be clear I have several access-point in our home environment, ik scheduled a time frame where the radio of the access-points go off for 5 minutes.

Have 3 filament bulbs loosing the connection to homekit but not to their own app. So it looks like wifi is not the issue here. But the ‘no response’ is so frequent they are hardly usable in homekit

I record nice the unusable irritation, for me the above mentioned workaround still does the job. Could you otherwise check with a ping to the bulb if it looses network connection before homekit looses connection?

I noticed at those moments they are still responsive in the yeelight app and therefore i don’t think they’re suffering from a bad internet connection.

Okey, then unfortunately I can’t help you. What I had seen was that if the bulb lost connection, it wasn’t available anymore within Homekit. When I powered it off and on again Homekit reestablished the connection again.

1 Like

A forced reconnect to the router does solve the problem for a bit but unfortunately only for a random periode ( few minutes to a few hours) i’m wondering since they are stable on yeelight own app if I can add them to the mi gateway and use them that way with homekit. Anyone experience with that?

I added them to homebridge with GitHub - vieira/homebridge-yeelight-wifi: Homebridge plugin for Yeelight white and colored bulbs. and that seems to be much more stable for now.

More stable but not stable. The bulbs are the worst smart bulbs I ever have bought. I moved one of the ap’s of my deco m5 system to the same room but the bulbs will not stay connected and/or loose connection to homekit or their own app.

Yeelight is a waste of money and support does not exist.

I give up, going to buy other bulbs

I’ve just fixed this by setting my 2.5Ghz Wifi access point to fixed channel 11.
I checked that this channel is the least busy (macOS wireless diagnostics) and I set it in the router settings instead of “Auto”:

My 3 Yeelight Color Bulbs II had been going offline for 2 years.

1 Like

Before replacing them I tried a final time to get them working did again a full reset but this time I didn’t even touch the homekit and let them run in yeelight mode only, used a raspberry and homebridge and unbelievable, they have been completely stable for two weeks now.

The problem is not wifi or anything, it is the homekit implementation that is completely rubbish.

Update, still no problems. So, don’t use
HomeKit until Yeelight fixes the problems.

I found a working solution for the problem that I also had with HomeKit.

The fix lays in the router settings in Wi-Fi channel setting. By default the channels are picked automatically. You need to set one specific channel and save. In my case it was 11 because it was the least loaded. You can make a test of channels to pick one. There are many YT movies showing how to do it. Just type “scanning wifi channels” or “how to scan wifi channels”.

That was the last thing I did in my router and I almost gave up. After that change I had not a single disconnect or search device ever. Everything works butter smooth. Siri also works very very quick by command. Have a try. Hope this helped someone.

I see that user @octoboar also did it and worked.

Cheers

I’m using AC + 2xAP, it seems the problem has been eased by disabling 802.11v and 802.11r WIFI network roaming

For me everything still stable, as long as i don’t activate homekit. So still using homebridge and yeelight plug-in. Everything stable and fast responding. Not what i wantend when i paid the extra for native homekit support, but it is as it is. In total 30+ homekit devices in my network that are all stable (even the ones that i made myself). My network is not the problem.

How i tired with all yeelight devices… problem after problem… every day i have “not responding” in homekit app… scanned my wifi and find best channel for my 2.4gh wifi, but not success… why, why all xiaomi products are so bad in terms of software??? i have 5 yeelight devices… i’m tired, and i never ever buy any of yeelight/xiaomi devices and will never suggest to other people!!! :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry: :angry:

1 Like

The problem is on their side. The only thing that works is the homebridge approach, completely stable now. See it it as a 3rd party universal gateway.

But I agree that is would never suggest anyone to buy these lights, that is for sure.