Yeelight pendant light - main light doesn't work


We just bought a Yeelight Crystal Pendant Light. The Ambilight works well with the App, but the main light doesn’t work at all.

We tried switching on and off for 5 times, but it still didn’t work.

Can anyone help me with this issue?

Uploading: pic2.jpeg…


Here is the picture:


hello I have the same problem.

Did you fix it ? If you do it, can you help me to fix it


We opened the light and found out that the cable of the main light wasn’t connected very well. After fixing the cable issue, it worked again.

You are right. The main light connection was displaced. I fixed it, now it is working.

Thank you for your help :slight_smile:

How did you open it?

How did you open the light? I have the same issue but I don’t know how to open it without breaking :confused:

Yeelight pendant light - main light doesn't work Gönderisinden tartışılmaya devam ediliyor:

I first disassembled the grey strip (underside) which is on top of frosted layer. Then you can easily take the frosted layer. afterwards I found the misplaced cable and clicked into place.