Unable to toggle schedule items on or off

Hi everyone:

I have had a couple of Yeelight Light Bulbs - an LED White Tunnable bulb and several Yeelight LED Colour Light bulbs. All are running the latest firmware. I also uses the Yeelight App on both IOS (iPhone) and iPad - all devices are running IOS/iPadOS 14.3. The Yeelight App I’m running is the latest version 3.3.30. I’m connected to the Asia and Oceania (Singapore) server.

I have several schedule items created for the bulbs, with various “Turn on” and “Turn off” times. However, on the main “Schedules” screen of the app, I usually only have one (or more) of the schedule items turned on at a time. In the past I could click on the toggle button on the right of the Schedules screen to toggle each schedule item on or off as I required.

However, just yesterday (I haven’t needed to toggle the schedules for a while), I’ve noticed every time I tried to toggle each item on or off, it actually brings me into the Schedule setting screen for the item instead, i.e. I can no longer toggle any items on or off. This was never the case in the past and it has worked pretty well over the past 2 years that I have had the bulbs.

Any schedule items, in its “enabled” state, still appear to work, although I seem to notice a new item I’ve added yesterday didn’t work (i.e. a light bulb didn’t turn off at the set scheduled turn off time).

I am wondering has anyone faced this issue? Looks like this may have been broken by the latest software versions, although this version could have been out for about a month now…?

I’ve attached a screenshot showing my scheduled items with some “enabled” and some “disabled”…

Thanks all.


Hmmm just a couple of hours after posting this, I noticed that an updated version of the app was posted on the App Store. Updated it on my iPhone and tried it, seemed to have fixed the issue I mentioned…

Will keep monitoring and see how it works out…