Connection timed out issue (still)

Cannot connect any of the 4 color bulb 2s I purchased. Attempted to log in to update firmware with all of the accounts I could find posted here, including the account posted 9 hours ago but still no luck. Changed server DNS, tried different Android device, etc.

Any other workarounds I can try before they go in the bin?

I have the same issue but my bulb is actually not new, it worked perfectly for months and now suddenly it stopped and I keep getting connection timed out error when I try to reconnect to it. I tried all solutions except DNS change because my internet provider doesn’t allow that, I logged in with that account but same issue each time without any success, I would really appreciate a solution as well.

1 Like

Same issue here. I have 6 or 7 Yeelights (Meteorite and Smart Square) which run for > 1 year on my 2.4 and 5 GHz network. No changes in passwords or other settings. One of the lights lost connection. I tried to reset ~10 times today, while changing various settings in between (e.g. DNS over HTTPs / TLS on/off, WPA2/3, 2 different Android phones).
No success. The app on my phone connects to the lamp, then it flashes briefly, stating “Updating connection status, just a sec…”. Then it times out. Please advise. This should not happen.

Hi there. The only thing that eventually helped me was to disable the password on the router.

I hope we can agree that turning off encryption on a private network is not a solution…

Same symptoms as Wolfsbein.
I can reset all of my Yee1 and Yee2 bulbs successfully.
However, after a power cut, my “strip plus” now always times-out.
It originally connected first time no problem.
One thing that I do notice is that the little blue led at the end of the strip controller goes from blinking to solid at about 75%, about where it would normally connect OK.
Hard to believe that this long-running problem remains unresolved.

After accidently leaving the app at “100% timed out” state for about an hour, I selected “Try again” and it connected immediately! :smiley:

Fixed properly now. In my case the power cut caused an IP conflict when the router restarted.
When my strip added in the app it got a conflicting IP.
Now after a router reset the IPs are correct.:smiley:

Tried to contact the support via the provided email today. Let’s see. Here’s what I asked for:

Dear Yeelight Support Team,

I am one of the many customers who have issues with connecting Yeelights to WiFi. Your own forum is full of such reports. I received my 2 Yeelight YLXD10YL Smart Square LED Ceiling Light somewhere in January / February this year. One of them somehow lost connection and is unable to reconnect.

I hope and honestly expect that you

  • Fix the issue
  • Provide a “cloud-less” solution to at least activate, control and operate your lights in local WiFi without them needing connectivity to your backend services

Please let me know when I can connect this expensive light again and do not have to sit in a bright white light all evening long. If you cannot do that, may I ask you for an additional Bluetooth remote, so I can at least control it manually.

All the best,

Yeah, obviously. I use a second router as a wifi extender, and I temporarily turned ott the encryption on the main router, then it managed to connect to my extender (same thing it was using for half a year without a problem) and then I put back the password on the main router and it managed to keep the connection.

I also contacted them and never received any answer…

I found a fix for me!

My timeouts were caused by an IP conflict that happened when my router restarted after a power cut.
Resetting the router solved it.

Damm even I am having a similar kind of issue, I have searched all over the internet and even have posted on number of threads on different forum, no solution seems to work. I am really frustrated, can anyone of you here help me resolve this issue, I am very much tired now.

Same here… any help ?