Yeelights work for a few hours, then unavailable, must be restarted

I have the same issue as apparently many others; Yeelights (12 Colour Bulb II and 2 Light Strips) will be available, and can be controlled via the Yeelight App and / or Mi Home app, but after a period 1-3 hours, they become “unavailable”, and must be power-cycled to become available.

This started happening over the last two weeks, where they had largely been reliable for a couple of years.

All are on the latest firmware, which is 2.0.6_0065 for the Color Bulb IIs.

I have tried both Mainland China and Europe (Frankfurt) servers.

I have tried three different routers.

I have also tried enabling LAN control.

I have also today tried Home Assistant as an experiment.

Nothing I have tried will make the keep the Yeelights available.

The behaviour seems very similar to that which was reported back in September 2019, as documented in this long thread:

Urgent firmware downgrade request (2.0.6_0051) Home Assistant Unavaliability

Again, I must emphasise, this not related to Home Assistant, this is affecting the Yeelight App and MI Home app.

If there is beta firmware available, please whitelist my MI account, which is 1901258438, I can use whichever server I have to make these lights work.

Thanks for any assistance!

Added:

I had made no changes to the server, or app firmware, or the network in my home, prior to the lights starting to go to “unavailable” after a short period of time (1-3 hours usually).

It makes no difference if the lights are on, or off, or distance from router (they can be 1m away, turned on, and still go offline).

2 Likes

+1

+1 Same problem, lights are now all but useless

Mi id 1612657592 Same problem after last update, few hours online and then completely offline.

same

1 Like

Good morning, the problem of disconnection had been bothering me for a month, every time I connected the bulbs after a while they disconnected. Yesterday I created a subnet with a router with ip 19.168.1.1 compared to 192.168.0.1, then I connected the lamp via yeelight app and the lampoda works perfectly. Today I’ll do some tests to verify why the lamps are disconnected with the main modem.
The main modem that does not maintain the connection with the lamps is a 3490 fritz box, while the router that works is a very simple Tplink wr841N.

+1

+1 Even tried different SSID.
I have 4 yeelight color bulbs that have this problem, and one yeelight color 4, which doesnt.

+1

Lease time setting on the router??

+1