Xiaomi Mi light bulb won't connect to Apple Homekit

Hello there,

I have a problem adding my Xiaomi Mi Smart LED Bulb Essential (white and color) to Apple Homekit or Home Assistant. The exact model type is: MJDPL01YL.

I have updated the bulb to the latest firmware (2.0.8_0019) and allowed access of the Xiaomi Home app to Apple Home.

When I hold tap on the device, inside the Xiaomi home app, I can see the bottom toolbar, I scroll right to the “Apple Home” icon, but the icon is disabled and I cannot tap it.

I have reinstalled the Xiaomi Home app and reset the bulb a few times, nothing changed. I even upgraded to iOS 14 and the problem persists.

Anyone had any luck with those bulbs in integrating them to Home Assistant or Apple Homekit?

I’m sorry, but this bulb doesn’t support Homekit.

that’s unfortunate, considering I researched and found out that Xiaomi announced in 2019 that Mi lights are now compatible with Apple Homekit before I purchased them ( https://blog.mi.com/en/2019/09/06/mi-led-smart-bulb-officially-supports-homekit/ ).

Are there any viable workarounds? Do these lamps work with any other software other than Xiaomi Home that has the potential to bridge to Apple Homekit or do I throw them to the trash?

I can’t even add these bulbs on the “Yeelight” iOS application.

Once I reset the bulb and connect to it via wifi on an SSID named “yeelink-light-color5_miap25FE”, the yeelight app recognizes the bulb and starts configuring it.

Then, it prompts me to rename the device but anything I input will result in an error “Name is too long” without any option to proceed.

Will this be resolved in a future Yeelight iOS app update?

I am attaching relevant screenshots.

Any suggestions @YeeTian?

It would be really disappointing to have to get rid of the bulbs because I can’t do anything with them.

You can add the bulbs through Mi Home app, the Yeelight app doesn’t support this product.

Any news on this? I got the same problem and Mi Home app won’t let me connect neither my first gen bulb nor my second gen one (the Homekit button is there but disabled).