Yeelight 1S Bulb unable to turn on again after switching off mains

So I got this from a local retailer and it works fine initially.
After using it for the evening, I used the LEAVE HOME button on the app to turn it off for the night.

Next morning as I left the house, I did the usual turn off the main power for the room. Coming back in the evening, I turned on the main power, and then tried to turn on the Bulb via the app. Doesn’t work anymore. After turning off and on again, it still didn’t work. So i tried resetting by turning on and off 5 times. But there was no more lights coming out after that.

I tested it on another E27 lamp that was working (it is using a Philips E27) and the Yeelight bulb did not even come on again after. Dead.

Can anyone tell me if it’s bulb that’s dead, or simply the software/control side of things?

I have the some problem… my yeelight lamp dont turn on, cant reset, dont blink , do nothing… its like dead… i dont know what i can do… and yesterday the lamp was working…but after take the cord of the power of the “light fixture” this lamp dont turn on anymore. But the other is ok. Mine is the version 2 of the yeelight.

I’m wondering if the bulb is dead as in hardware dead… or is it a software thing where it can’t power on.

But I’ve tried to reset it by following the instructions.
Power on, 2 secs, Power off 2 secs and repeat 5 times.
Still can’t power on.

So frustrating.

I tryed to reset too… but nothing… no light, no blink, nothing…

Hi!! Mine works again… u just need to forget it about this, and one day the lamp works again… thats crazy…

I’ve already sent my bulb back to the vendor for a refund, and bought another one elsewhere.
Tried everything, can’t even power on to reset.
I gave up.